Visual Effect
金在奎
SUCCESS STORY
Lynda Thompson - (Evan Almighty; Haunted Mansion)
The first film I worked on was Tron... I was an assistant scene coordinator and I learned about animation, animation cameras, and the specifics of visual effects while working directly with a wonderful mentor...
For the next 10 years I worked on numerous films as a VFX Coordinator and a VFX Production Supervisor. I also had the opportunity to work at several different companies and that added to my learning experience. In those days credits were still evolving and I received the title VFX Producer for the first time on Dave in 1993.
I have been working as a VFX Producer for over 15 years... My father and grandfather were both in visual effects but I graduated from the University of California, Irvine, with a B.A. in English and initially thought I would go a different route and become a journalist. Now I can't imagine that I almost made that choice.
The essential duties of the VFX Producer are breaking down the script, budgeting the VFX, overseeing the production of the VFX during prep/shoot/post and communicating well with the production and VFX teams. The responsibility of the VFX Producer is to facilitate delivery of final shots within the agreed-upon budget and time.
Keys to Success: Being able to see potential problems well in advance is one of the most important qualities for the job. A VFX Producer is responsible for keeping everything running smoothly. I believe the best VFX Producers steer the team away from pitfalls in a calm, decisive manner. The database keeps us informed on each shot's current status, an essential part in being able...
Figure 17.2 An example of an approval sheet for multiple shots that the Editor and VFX Supervisor can approve.
Stop-Motion Animation

Stop-motion animation is probably the oldest visual effects technique. It is based on the ability of a motion picture camera to shoot a series of frames one at a time instead of in a continuous burst of film, as is normally the case.

As early as 1897, two American film pioneers produced a short film called Humpty Dumpty Circus in which they moved a child’s toys by stopmotion, and in 1898 the French film pioneer Georges Méliès used stop-motion to animate wooden letters for what today we would call a commercial.

Stop-motion animation is a bit like traditional two-dimensional (2D) cartoon (or cel) animation in that an animator makes small changes in the subject’s position from one frame to the next. In traditional animation, the animator creates the sense of movement by drawing a character on paper or a 2D sheet of acetate (called the cel) in a slightly different position in each frame. But in stopmotion, the animator moves a three-dimensional (3D) model in small increments from one frame to the next so that its movements will look smooth and continuous when the film is projected at the normal 24 frames per second. The technique is also called “dimensional animation.”

Undoubtedly the most famous practitioner of
Undoubtedly the most famous practitioner of this technique is the legendary Ray Harryhausen. He inspired a whole generation of animators and present-day visual effects artists with his classic stop-motion work in movies like the original Mighty Joe Young (1949), Jason and the Argonauts (1963), Clash of the Titans (1981), and many others.

The technique is still very much alive today, but today’s stopmotion animators have a wide array of digital and electronic gadgetry at their disposal that enables them to create some truly wonderful animation. In fact, we would argue that it was the development of sophisticated electronic and digital tools that led to a revival in recent years of stop-motion films.

Beginning with The Nightmare before Christmas (1993), followed in 2000 by the hit Chicken Run, and later by such delightful stop-motion masterpieces as Corpse Bride (2005) and Coraline (2009), stop-motion artists could avail themselves of such technological innovations as motion control, digital image manipulation, and digital compositing that did not exist in precomputer times.
Stop-motion animator Stephen Chiodo on stop-motion set.
(Image courtesy of Chiodo Bros.)

Animator Stephen Chiodo poses a dragon puppet.
(Image courtesy of Chiodo Bros.)
Puppets and Animatronics

Puppets are artificial creations that simulate a living creature, whether human or not. Puppets can be animated very simply by hand, wires, cables, rods, or — more likely these days — animatronics. Strictly speaking, animatronics is the control of motorized puppets through the use of electronics. But over time, the word animatronics has become kind of a catch-all term that covers electronic, mechanical, hydraulic, or radio-control devices. We just need to be clear that when we say that something is animatronic, we are merely talking about how a character is animated, or made to move. It does not mean that the entire character is artificial. In other words, a puppet is artificial by definition, but it is not necessarily animatronic.
Matte Paintings

A matte painting is a painting that adds to or replaces part of a live action image. Matte paintings are used to create imaginary environments or to replace part of a scene to add complexity to a shot that would otherwise be too expensive or impossible to film. They have been called the invisible art, because when they are done well, viewers cannot tell that they are looking at a painting.

Matte paintings have their roots in what are called glass shots, a technique that predates motion pictures. Early still photographers would sometimes aim their cameras at a subject and find that the existing scene was not to their liking. Their solution lay in setting up a pane of glass between the camera and the subject, then painting a different scene directly on the glass so that the painting blended seamlessly with the subject they wanted to photograph. It was just such a photographer, Norman Dawn, who was apparently the first cinematographer to apply the glass-shot technique to motion pictures, after having learned the trick while a still photographer. Unfortunately, glass shots had to be set up and completed at whatever location the action took place, be it city or desert, come rain or come shine. Glass shots enhanced many a film for decades, but they were gradually replaced by true matte paintings after the invention of optical printers in the 1920s. With optical printers, a live action scene could be filmed on location, but the accompanying painting could be completed at a more leisurely pace in the studio.
Matte artist Syd Dutton of Illusion Arts at work on a digital matte painting. Today, virtually all matte paintings are created digitally. (Image courtesy of Bill Taylor, ASC)
In-Camera Miniatures

The “purest” form of using miniatures is in-camera. As the term implies, these are stand-alone miniatures that are filmed and can be cut into the film as is. In-camera miniatures often involve the destruction of the miniature, as when a building or a vehicle is blown to smithereens. But explosions, flowing water, and other natural phenomena have minds of their own. As often as not, something unpredictable will happen, the miniature will have to be restored, and the shot will have to be done over. VFX Producers need to be aware of this for budgeting and scheduling purposes. The common practice is to budget and schedule for three repetitions of these events . . . just in case the first two don’t work out.

Hanging Miniatures with Live Action

Hanging miniatures are also called foreground miniatures. The terms are virtually interchangeable. This is an in-camera technique where a miniature is built close to the camera and lined up and painted so that it blends perfectly with a live-action background. Hanging miniatures can be a very effective and relatively inexpensive means for a director to give a grander scale to a set or to create an imaginary environment that doesn’t exist in the real world. It’s the same basic idea as matte paintings, except that hanging miniatures have the advantage that they are 3D objects, which almost always look better than a 2D or even a 3D digital painting.
VFX Supervisor Rob Legato lines up a shot on a foreground miniature. (Image courtesy of New Deal Studios, Inc.)

Miniatures with Composited Elements
This technique involves the compositing of a miniature either with a live-action plate, a matte painting, or some form of computer-generated background that will supplement the miniature photography. Compositing miniatures with other elements is probably the most common use of miniatures, and certainly one of the most widely used visual effects techniques. The Lord of the Rings and Harry Potter trilogies, for example, were full of such shots.
1주차

Front and Rear Projection
Forced Perspective with Live Action
Blue- or Greenscreen Composites
Motion Control
In-Camera Practical Effects
Special (Mechanical) Effects and Visual Effects
DIGITAL EFFECTS: THE 15-MINUTE VERSION

Two-Dimensional (2D) vs. Three-Dimensional (3D) CGI

2D CGI

3D CGI

Creating a Digital Image

To create an image in 3D CG you basically have to accomplish five things:

- Build a model
- Texture and paint the model
- Animate the model
- Render the model
- Composite the model with other elements

CG Characters

Animation

Rendering

Compositing

Miniatures vs. Digital Models
SUCCESS STORY
Tom Boland - (Blood Diamond; The Last Samurai)

I moved to Los Angeles ... with the hope of getting into the film or television industry. My brother told me he worked for a production company and that he needed a driver to pick things up for the company ... I didn’t really want to do it ... but he kept badgering me through the evening until he finally said that I’d be doing him a real favor if I would do it. I showed up for work at Apogee Productions, which at the time was one of four full-service visual effects companies in the world, headed up by Academy Award winner John Dykstra. I had never seen such a place ... .I was in awe ... .I ended up working there on staff for 5 years and worked my way up to production assistant, then became the purchasing agent ... After that stint, I became a production coordinator and then a VFX Producer. It was 5 years of Visual Effects College, working with the best in the business and I loved going to work there every single day. I have now worked as VFX Producer since about 1991.

I think the most important duties of a VFX Producer are to enable the “creatives,” the VFX Supervisor, director, etc., to do their best work possible within the restraints of a budget. This means you have ... to be prepared to come up with solutions to problems that arise throughout the production so that you never have to say as a producer “no”, unless you absolutely have to. I think trying to keep reality afloat in the midst of craziness is also a huge duty of the VFX Producer.

Key personality traits for success include honesty and integrity first and foremost. Then thinking ahead, being prepared, having a plan B and C, rolling with the changes, having a sense of humor, and being able to be firm when you have to — all vital.

In any business you also have to have the ability to suffer fools gladly because you will run into many in your career.
SUCCESS STORY

Jenny Fulle - (Apollo 13; Spider-Man 1, 2, & 3)

My career in visual effects began in 1980, working as a janitor for George Lucas. I worked for Lucasfilm for over 8 years, moving from janitorial, to the mailroom, production assistant, and eventually VFX Coordinator. In those early days, the role of VFX Producer didn’t really exist; VFX Coordinator was it. I continued to work my way through the ranks while working at such facilities as Boss Film, 4-Ward Productions, Digital Domain, Warner Digital, and Sony Imageworks. My first opportunity to work as a VFX Producer was given to me by 4-Ward Productions in 1992.

It was in the early 80’s, working at ILM right out of high school, that I knew I wanted to work in VFX, and production in particular. It was impossible to resist the energy, passion, and personalities of those modern-day pioneers who were creating fantastic images for films that would entertain and touch the lives of so many.

The role of the VFX Producer is to create a synergy between the visual artistry and budgetary limitations so that vision of the film is given as much room as possible to be explored and brought to life within the context of a finite amount of resources.

The traits that I have found most valuable in being effective as a VFX Producer are common sense, open-mindedness in finding common ground to work with a dizzying array of personalities, and ability to constantly multitask and look ahead. A good VFX Producer must be willing to help steer the direction of a project and take an active role in ensuring its success.
Exploring Particles

Particle Simulation

Particles are versatile and can be rendered in a multitude of ways. Relatively inexpensive to simulate, they can look like sparks or a splash of water. Particles can also be used to drive geometry or be driven by other simulations. Their adaptability makes them a powerful and resourceful tool.

Simple points in space, these objects exemplify the law of inertia: An object in motion tends to stay in motion unless acted upon. Particles are calculated with no understanding of the world around them. A particle simulation does not solve for atmospheric factors such as air density, pressure, and temperature. Particles are allowed to move unencumbered through space. It’s possible to impose restrictions on them through fields and expressions, but once a particle, always a particle. You can’t change what it was born to do.

Many scientists accredit the creation of the universe to a cosmic explosion. Referred to as the Big Bang, it is the idea that the universe exploded from a central point in space and is still expanding today. Millions of particles were fired into the blackness, all at different velocities. The farther from Earth they are today, the faster their initial speed. Whether you believe this theory or not, computer-generated particles operate in the same manner.
To understand particle simulation, in this chapter you’ll look at what it takes to create a big bang explosion. The point isn’t to create something realistic or perfectly crafted. The goal of this chapter is to show you the anatomy and functionality of particle simulation. Even if you have worked with simulation before, it’s important to work through this chapter. Simplistic on the surface, it addresses key nodes usually hidden from view. Following Newton’s laws of motion, simulated particles have very little inherent motion. They are the simplest form of simulation. You could say they can’t think for themselves. They must be told what to do. That’s fine as long as you want to simulate stuff in outer space, where air and friction don’t exist. If you are simulating under Earthlike conditions, then it is up to you to direct every aspect of the particle simulation. This typically requires extensive use of fields and expressions.
Project: Building a Solar System

The particles are emitted in every direction.

The spheres and particle points explode out from a single point in space.

The number of particles is displayed in the Attribute Editor.

The planets' distribution is more spread out after changing the Random Stream Seeds setting.
Emitters are not necessary for particle simulation, but they play an essential part in the creation of many types of effects. Being in charge of particle distribution, they control speed, spread, and direction. Particles can be painted into a scene or attached to geometry, but emitters are the easiest way to control varying amounts of particle emission. Emitter icons function like any other node. They can be animated or placed into a hierarchy. The only exception is that scale has no influence. Even though emitters have internal directional controls, you can still rotate them and alter particle bearing. Particle emitters have a simple function: to emit particles into a scene. Although the concept is basic, your control over particle emission goes far beyond that. A lot is determined before the particle ever leaves the emitter. From birth, particles begin to age. Even if a particle lives forever, it still has an age, and this age can be called upon to influence other properties.
Project: Creating a Comet

1. Open the scene file comet1.ma. The scene contains a polygon sphere traveling on a curve. The animation runs from 1 to 500. The geometry has been named comet and added to a layer of the same name. It is also textured. Select the comet node and choose Particles ➔ Emit from Object. Change the Emitter Type to Directional and make sure the direction is 1 in the X axis. Change the Spread to 1 and make sure the Rate is 100.

2. Play the animation. A lot of particles accumulate onscreen during playback. The particles should eventually die off. Select the particles. In the Attribute Editor, set the Lifespan Mode to lifespanPP only. Add the following Creation Expression to the lifespanPP attribute listed under the Per Particle (Array) Attribute tab: particleShape1.radiusPP=rand(1,2)

   Play the animation again. The particles die off randomly but abruptly. The look should be slower and more drawn out. Instead of using the random expression, change it to Gaussian: particleShape1.radiusPP=gauss(1,2)

   Using the Random function is like rolling dice to get a value. The Gaussian option pulls numbers from a bell curve. Although still random, the Gaussian values have a greater chance of being closer together, giving a more rhythmic look. Play the simulation again to observe the difference between Random and Gaussian.

3. Add an rgbPP attribute by clicking the Color button in the Attribute Editor. Choose Add Per Particle Attribute. Right-click in the new attribute’s field and open the creation options for Create Ramp. Use the particle’s age for the Input V. Change the ramp’s colors to represent a white-hot burning flame that fades to dark smoke. Use Figure 1.10 to color the ramp. Figure 1.11 shows the progress of the ramp.
3. Add an rgbPP attribute by clicking the Color button in the Attribute Editor. Choose Add Per Particle Attribute. Right-click in the new attribute’s field and open the creation options for Create Ramp. Use the particle’s age for the Input V. Change the ramp’s colors to represent a white-hot burning flame that fades to dark smoke. The progress of the ramp. If you are new to ramps, the start of the ramp is at the bottom. The particle reads from bottom to top or, using the default ramp colors, from red to blue.

4. As a finishing touch, add an opacityPP attribute to make the tail of the comet dissolve over the life span of the particle. Create a ramp by using the default ramp for one-dimensional attributes, white (opaque) for the start and black (transparent) for the end.

5. Test other particle types to see what makes the comet look the best. shows the comet with particle clouds.
Hardware Rendering

Rendering through your computer’s hardware can be likened to taking a screen capture at every frame. Although a hardware render is more complex, it produces essentially the same results as those you see during a playblast. Some extra features enable you to add motion blur as well as some texture support. For instance, you can render bump maps and high-resolution images, particularly useful for sprite particles.

Even though hardware rendering is seemingly simple, very complex results can be achieved. It shows particle points in a viewport window. The same particles rendered with motion blur, demonstrating what can be done in hardware rendering. Through multiple passes and motion blur, high-quality results can be achieved. The comet created with hardware rendering. The benefit of hardware rendering is speed. You can rapidly produce finished animations by utilizing most of the features used in software rendering.
Hardware Rendering

Rendering through your computer’s hardware can be likened to taking a screen capture at every frame. Although a hardware render is more complex, it produces essentially the same results as those you see during a playblast. Some extra features enable you to add motion blur as well as some texture support. For instance, you can render bump maps and high-resolution images, particularly useful for sprite particles.

Even though hardware rendering is seemingly simple, very complex results can be achieved. It shows particle points in a viewport window.

Figure 1.18 shows the same particles rendered with motion blur, demonstrating what can be done in hardware rendering.

Through multiple passes and motion blur, high-quality results can be achieved.

Figure 1.19 shows the comet created with hardware rendering. The benefit of hardware rendering is speed. You can rapidly produce finished animations by utilizing most of the features used in software rendering.
The comet rendered with hardware or arnold rendering
Some types of particles can be rendered through Maya’s software renderer. Maya flags these with a (s/w) under the Particle Render Type options. This opens the door to attributes and quality not accessible through hardware rendering. Software-rendered particles require a shader or material in order to be rendered properly. The following exercise takes you through the process.
Software-Rendered Comet

Our first comet project used a sphere to emit particle points. Using that project as a base, this project replaces the particle points for clouds. In order to render the cloud particle type we must add a shader.

1. Open the scene file cometSoftware1.ma. The scene picks up where comet2.ma left off. The animation runs from 1 to 200. In the previous comet project, you added per particle ramps to describe color and transparency. These same techniques are used in software rendering, but are applied through a particle cloud shader. The Cloud particle type was added at the end of the comet exercise. Clouds have a more noticeable and detailed radius than particle points. To take advantage of this, create a radiusPP attribute. Add a ramp by using the Particles Age for the Input V. Change the start grayscale value to 0.373 and the last to pure white. The middle color is not necessary. Use Figure 1.20 as a guide.

2. Open the Hypershader. Assign the particles to the particle cloud shader called comet_Mat. Select the shader and the emitted particle. Graph the input and output connections in the Hypershader. The ramps from the particle can be transferred to the particle cloud. There are many ways to accomplish this. Perhaps the easiest way is to open the particle cloud shader in the Attribute Editor and drag the ramps onto the desired attributes. Drop the ramps into the Life Color and Life Transparency channels. The normal Color and Transparency channels are automatically connected as a result. Figure 1.21 demonstrates. Notice that Particle Sampler Info nodes are created when the amps are added to the particle cloud. These nodes enable you to drive shader attributes with per particle attributes. You can also control how the shader values are mapped to the particle attributes. The Life Transparency map we pulled from the previous project is actually backward. The particles are transparent at the beginning of their life and not at the end. Instead of altering the map, open the Particle Sample node and select the Inverse Out UV check box. This effectively flips the way the ramps’ values are mapped.
2주차

Figure 1.20 Create a ramp for the radiusPP.

Figure 1.21
Drag and drop the particle ramps onto the corresponding particle cloud attributes.
4. In addition to self-illumination, the comet needs a glow. Add a white-to-black ramp for the Glow Intensity attribute. Move the black position to 0.21, once again to separate its effects from the smoke trail. Set the white color value to 1.5 to increase the glow's intensity.

5. The Transparency section offers several great attributes for creating complex effects. To keep things simple, adjust only the following settings:
   - Density: 0.719
   - Blob Map: 0.5
   - Roundness: 0.107
   - Translucency: 0.5

6. The shader is finished. The particle cloud shader creates a smooth dissipating smoke trail. As the smoke fades away, it should also lose speed. Change the Conserve attribute of the particle to 0.95. Play back the simulation and observe the differences. A little less Conserve goes a long way.

7. Open the Render Settings window and use the Production Quality preset. Render the animation. Figure 1.23 shows the results from frame 100.
Figure 1.23
The results of the software render at frame 100

2주차
Create Particle basic
- It is necessary to construct interface for Effect work. Make it a habit to work on with Outliner opened aside.
- Click the icon down on the left hand side as in the picture below or select Window > Outliner on Maya bar at the top.
Particle Tool
- Let's learn how to create particle using Particle Tool.
- You need to switch the tab below File at the top on the left into Dynamics.
- Select Particles > Particle Tool at the top and directly create particle at the location you want using the mouse.

- However, the method described above is used with a certain purpose and particle is usually created in a different way.
  - Create the particle repeatedly and find out what the problem is through selecting particle and applying Translate, Rotation and Scale.
Emitter type: Particle emission mode
- Run Particles > Create Emitter. The Emitter here means an entity to create particle.
- Select a particle, open the Attribute Editor using Ctrl + A and move on to emitter tab. You can see the Emitter Type set as Omni as default.
- There are Directional, Omni, Surface, Curve and Volume. Test them one by one.

Rate: Particle emission amount
- Emission amount per second
- Adjust the Rate(particles/sec) as in the picture above and test them.
3주차

Speed : Speed of particle emission
  - Control the speed by altering the value for Speed.
  - Speed Random : This means randomness of speed that Particle has. With higher value, each particle moves at a different speed.
3주차

Emit from Object
- Designate an object and make it Particle Emitter.
- Create one object as below, select the object and run Particles > Emit from object.
- Go into Attribute Editor of Particle and switch the Emitter Type into Surface on the emitter tab.
Use of Particle Fields
- You can control particle's motion using various fields.
- Gravity: This applies the force of gravity onto particle.
- Select the Particle and run Fields > Gravity. Test each option in Gravity Field.
Particle Collision
- Simulate the collision of particle and an object using the Particles > Make Collide tab.
- Arrange the object to be collided on the floor, make the particle fall down from above and select object first and then the particle along with it. Run Particles > Make Collide as below (and test by switching values in option of Collision which includes Resilience, Friction and Offset).
Particle Collision Event
- Create the second particle on the already collided one at the Particles > Particle Collision Event Editor tab.

- Run the Particle Collision Event Editor, set as the image above and operate Create Event. Then the second particle is created on the particle collided with floor.
Concept of Lifespan - This means life of particle. Lifespan Random gives random value to particle life. Select Particle, open the Attribute Editor and set as Lifespan Attributes > Lifespan Mode > Constant. Give a proper life to Lifespan.

Particle Render Type - This decides the shape of particle. Switch it to Streak and make setting as below - then, the bar-shaped particle is displayed.
Use the Particle Collision and Particle Collision Event.

- Splash is displayed through collision with the floor.

- Run the Particle Collision Event described in subunits above and adjust the Particle Render Type and Lifespan of the second particle.
Placing Dust Puffs with 2D Fluid Effects
Maya’s Fluid Effects system replicates a wide range of fluids in motion. This includes atmospheric phenomena, such as smoke and cloud vapor, and fluid bodies, such as water or molten rock. Fluid Effects are available via the Dynamics menu set and are created through three main methods:

• A 2D or 3D fluid dynamic container holding fluid voxels
• The Ocean system, which creates a large-scale water surface
• The Pond system, which creates a smaller-scale water surface

The Ocean and Pond systems are discussed in Chapter 4 week. In this chapter, we’ll use 2D and 3D fluid dynamic containers. The containers employ Navier-Stokes fluid dynamics equations with each frame to determine the property values of fluid voxels. (Voxels are three-dimensional pixels that serve as the basic building blocks of the fluid simulation.)
Creating a 2D Fluid Container and Emitter

To create a fluid simulation with a container, you can follow these basic steps:

• Create a fluid container
• Add Density and Velocity properties to the container
• Optionally, add Temperature and Fuel properties to the container
• Add color to the resulting fluid
• Play the simulation using the playback controls

There are several ways you can add Density, Velocity, Temperature, and Fuel properties to a container:

• Add a fluid emitter
• Interactively paint fluid properties
• Emit fluid properties from a polygon or NURBS surface
• Emit fluid properties from nParticles or particles
• Apply a predefined gradient of property values

To see a fluid as a shaded mass within the view panels, you must choose Shading > Smooth Shade All through the view panels’ menus. Otherwise, the fluid is represented by small dots in the wireframe view.
We’ll use this to create a puff of dust as the bundle of dynamite falls on top of the foreground rock. You can follow these steps:

1. Through the Dynamics menu set, choose Fluid Effects > Create 2D Container. A square container, named fluid1, is placed at 0, 0, 0. Using the Channel Box, scale the container down to 0.5, 0.5, 1.0. Rotate the container to 0, 80, 0. Interactively move the container so that it rests on top of the rock where the dynamite bundle makes contact (roughly 7.4, 3.5, 13.3 in x, y, z). With the container selected, choose Fluid Effects > Add/Edit Contents > Emitter. A fluid emitter is parented to the fluid1 node.

2. Play back the timeline. A fluid simulation occurs within the container. The fluid is shaded white. The fluid represents a material, such as water vapor or smoke particles. The fluid is born at the container’s center where the emitter is located. To move the emitter to the bottom of the container, select the fluidEmitter1 node in the Hypergraph or Outliner and use the Move tool in a view panel.
Reviewing Fluid Nodes and Fluid Textures
Before adjusting the fluid simulation, an understanding of fluid nodes is helpful. When a fluid container is created and an emitter is added, a network is created that includes a fluid transform node, a fluid shape node, and a fluid emitter node. The fluid emitter is automatically parented to the fluid transform node. The fluid shape node creates the container seen in the view panels and defines the fluid contents in terms of properties. The fluid shape also serves as the shader for the fluid and is found listed in the Materials tab of the Hypershade window.

In contrast, Fluid Texture 2D and Fluid Texture 3D textures generate fluid-based textures that you can map to the attributes of materials. The texture attributes are identical to a fluid shape node. However, a place2dTexture node is connected to the Fluid Texture 2D texture node, which results in the fluid pattern being mapped directly to the assigned surface. On the other hand, the voxels of the Fluid Texture 3D container supply their color values based on the assigned surface position relative to the texture container.

Working with Fluid Properties
A fluid emitter creates fluid property values that modify the container voxels as the timeline plays. The properties are divided into Density, Velocity, Temperature, and Fuel:
- The Density property adds the fluid to the system (that is, it adds the virtual fluid substance). As the dynamic simulation unfolds, each voxel receives an updated Density value that represents the amount of fluid in that voxel.
- The Velocity property adds motion to the system by moving Density, Temperature, and Fuel values among the voxels. Each voxel is given a vector that includes magnitude and direction. Each voxel’s vector changes over time as the dynamic simulation is calculated. Velocity values are affected by the fluid shape node’s internal forces (Gravity, Viscosity, Friction, and Damp, found in the Dynamic Simulation section) and/or added dynamic fields.
- If the Temperature property is added, the voxels store a temperature value (which may cause the fluid to expand, contract, speed up, slow down, or ignite).
- If the Fuel property is added, the fluid’s “state of a reaction” is stored. The fluid in any given voxel is unreacted, completely reacted, or is in a transitory state. When Temperature is added, the fluid can ignite, causing Density and Fuel to diminish over time. This allows fluid dynamics to create physically-based explosions.

A fluid emitter must be within the bounds of the fluid container to function. You can add multiple emitters to a single container. To do so, select the container, and choose Fluid Effects > Add/Edit Contents > Emitter.

The specific way in which properties are added to the container over time is dependent on the Contents Method section of the fluid shape node.
The Density, Velocity, Temperature, and Fuel attribute menus offer four options:
Off(Zero) The property is not added.
Static Grid The property values for voxels are provided, but a dynamic simulation for the property is not undertaken.
Dynamic Grid The property values for voxels are provided and updated as the dynamic simulation unfolds.
Gradient The voxel values are tapered in one direction, but do not update over time. This is suitable for making static fluid bodies, such as fog that gets less dense in the Y direction.
Open the fluidShape1 node in the Attribute Editor. You can select the fluid container in a view panel. Expand the Contents Details section and the Density subsection.
Change Buoyancy to 8, Dissipation to 0.8, and Diffusion to 1.0. Buoyancy simulates the difference in mass density between regions with fluid and regions without. Higher Buoyancy values cause the fluid mass to rise more rapidly.
Dissipation determines how rapidly the fluid mass breaks up and spreads out. Diffusion averages the Density values so that the fluid mass appears softer and more amorphous. High Dissipation and Diffusion values make the leading edges of the fluid mass smoother and less convoluted. Play back the timeline from frame 1. The fluid creates a less cohesive, more cloud-like form.
Adding Fog with 3D Fluid Effects

2D fluid containers differ from 3D fluid containers in that they have a single voxel forming the container depth. When you use 3D containers, you can create more complex fluid shapes. You are also free to move one or more emitters through the 3D container to create a trailing fluid effect.

Setting Up a 3D Container

You can use a 3D container in combination with a gradient Density to create a receding fog in your scene.

1. Choose Fluid Effects > Create 3D Container. A new container is placed in the scene. Interactively scale and move the container so that it surrounds the entire model. Place the bottom of the container so that it is slightly below the ground surface (approximately −21, 35, 0 in x, y, z). Note that the lower face of the container is marked with a grid—this indicates the direction of the container’s local Y axis.

2. Open the new fluid shape node’s Attribute Editor tab. In the Content Methods section, change the Density menu to Gradient. The container fills with fluid. Change the Density Gradient menu to X Gradient. This causes the fluid Density values to run from 1.0 to 0 along the local X axis. This creates the illusion that the fog is thicker further away from the camera. Set the Velocity menu to Off(Zero). The resulting fluid will remain static.
3. Expand the Contents Details section and Density subsection. Note that most of the attributes are grayed-out and inaccessible. Change Density Scale to 0.1. The fluid becomes less dense and more transparent.

4. Expand the Shading subsection. Change the Selected Color swatch for the default graph ramp point to light blue. Test render. A bluish fog appears. If rendering artifacts are present, such as color banding, checkered squares, or a row of small dots, you can raise the Quality value in the Shading Quality section. By default, fluids are lit by lights in the scene. Fluid also supports depth map and raytraced shadows. Hence, in denser areas of the fluid, cast shadows of objects are visible. For example, the irregular wood slats on the side of the mine entrance cast diagonal shadows through the fluid mass.

**Working with Fluid Textures**

The fluid shape node includes a Textures section. This section allows you to map the fluid’s color, incandescence, or opacity with a built-in fractal noise pattern. The noise carries attributes similar to the Noise texture. The noise is mapped to the fluid as a static or dynamic pattern through the Coordinate Method menu. If the menu is set to Fixed, the texture is fixed and does not change during the playback. If the menu is set to Grid, the texture dynamically moves as the voxel values change over time.

As an alternative, you can map various attributes in the Shading section with 3D textures. For example, you can map a Stucco texture to the Selected Color of the Color graph ramp default point and thereby produce fog that has a soft mixture of two colors. As another example, you can map a Volume Noise texture to Transparency and create an irregular density throughout the container. To apply this technique to the Project 3 fog, follow these steps:

1. Open the fluidShape2 node’s Attribute Editor tab. In the Shading section, click the checkered Map button beside Transparency. Select the Volume Noise icon in the Create Render Node window.
2. In the volumeNoise1 tab, set Threshold to 0.2 and Amplitude to 0.5. This reduces the contrast within the noise pattern. Set Scale to 0.5, 0.5, 0.5 to reduce the size of the noise grains. Set Noise Type to Perlin Noise, which produces a softer noise pattern. Test render. The fog gains additional variation in its density (Figure 6.10). To see the variation more clearly, temporarily hide the Hill surface, return the camera’s Background Color to black, and render again. Continue to adjust the Volume Noise attributes until the density variation is acceptable.

**Trailing Smoke with 3D Fluid Effects**
A fluid dynamic emitter need not remain static. You can animate the emitter moving through the container. As the emitter produces fluid, a fluid trail forms. This is ideal for creating a thin wisp of smoke emanating from a flame.

**Parenting and Animating a Fluid Emitter**
To add a smoke trail to the dynamite fuse as part of Part 4 of Project 3, follow these steps:

1. Choose Fluid Effects > Create 3D Container. Interactively move and scale the new container so that it sits on top of the foreground rock and encompasses the area in which the dynamite bundle moves. Make the Scale roughly 0.6, 0.6, 0.6 and the position roughly 8, 5, 14.

2. With the container selected, choose Fluid Effects > Add/Edit Contents > Emitter. A new emitter, named fluidEmitter2, is placed in the volumetric center of the container. Return to frame 1. Move the emitter to the tip of the fuse. (Optionally, you can use the Snap To Points magnet to snap the emitter to the bundle surface.) With the emitter selected, Shift+select the dynamite bundle and choose Edit > Parent. Play back. The emitter drops with the dynamite, producing a trail of new fluid. Note that overlapping 3D containers do not interfere with each other. Emitters are added to specific containers and will not interact with containers they are not added to.
3. Return to frame 1. Select the fluidEmitter2. In the channel box, keyframe the Translate X, Y, and Z attributes. (Click-drag over the attribute names to highlight, then RMB-click over the highlighted names and choose Key Selected.) Play back and stop at frame 90. Use the Step Forward One Frame button repeatedly so you can stop the playback more accurately. Interactively move the emitter to the base of the fuse and keyframe the Translate X, Y, and Z. Play back. The emitter falls and simultaneously moves down the fuse. Note that you can temporarily hide other emitters and geometry to see the new fluid simulation more clearly.

4. At this stage, the fluid is thick and amorphous. To create a thinner trail, you can create smaller voxels. In the fluidShape3 tab, change Base Resolution to 48. The container is filled with 48x48x48 voxels. Smaller voxels create smaller changes within the fluid simulation. However, the higher the Base Resolution, the slower the dynamic calculation. Return to frame 1. Note that the grid at the base of the container updates to indicate the higher resolution. To make the voxels even smaller without raising the Base Resolution, scale down the entire container. Through the channel box, set the Scale to 0.4, 0.4, 0.4 and change the Translate to 8, 4, 14. Keep in mind that the fluid cannot extend past the container and may collect along the sides and top of the container if the position is not carefully chosen.
Using a Volume Fluid Emitter and Graph Ramps

At this stage of Part 4 of Project 3, the fluid is widely dispersed as it is generated by the emitter. As an alternative, you can emit fluid from a volume shape.

To do so, follow these steps:

1. Open the fluidEmitter2 Attribute Editor tab. In the Basic Emitter Attributes section, change Emitter Type to Volume. Scroll down to the Volume Emitter Attributes section and change Volume Shape to Sphere. The volume emitter works in a similar fashion to one used for nParticles. In this case, Density values are added to the voxels that fall within the emitter sphere. Play back. The fluid is barely visible and does not appear at the fuse itself. The net Density values are so low that the fluid is not visible in some areas. Return to the fluidEmitter2 tab. In the Fluid Attributes section, raise the Density/Voxel/Sec below Density Method to 4.0. This quadruples the Density values assigned to each voxel that falls within the volume sphere. Play back from frame 1. The fluid forms a column. To make the column thin but continuous, reduce the Scale XYZ for fluidEmitter2 to 0.3, 0.3, 0.3 through the Channel Box (Figure 6.12).

2. Return to the fluidShape3 Attribute editor tab. Expand the Contents Details section. In the Density subsection, change Density Scale to 4. This further “thickens” the fluid. Change Buoyancy to 8. This gives the fluid a stronger desire to rise. Change Dissipation to 0.2 and Diffusion to 0.1. This begins to soften and spread out the fluid mass. In the Velocity subsection, change Swirl to 10. Swirl imparts swirling motion to the fluid as it travels. In the Turbulence subsection, change Strength to 1.0 and Frequency to 0.1. This imparts additional chaotic motion. Play back from frame 1. The fluid begins to take on an undulating, smoke-like look.
A small sphere volume emitter and increased container Base Resolution creates a thin fluid line.
4주차

3. Test render from the Persp camera (temporarily hide the background geometry). The fluid is difficult to see. To solve this, scroll down to the Shading section of the fluidShape3 tab. Change Transparency to 0, 0, 0.1 in HSV. (Note that a Transparency value of 0, 0, 0 makes voxels with non-0 Density 100% opaque.) Test render. The fluid becomes visible.

4. To make the fluid smoke appear more sooty, change the default point of the Color graph ramp to dark gray. Note that the Color Input menu for the Color subsection is set to Constant. With this setting, the fluid is colored with the left-most graph ramp value. Change the Color Input menu to Density. This correlates the ramp to Density values. In this case, voxels with high Density values receive color values from the right side of the ramp. Voxels with low Density values receive their color values from the left side of the ramp. Click center of the ramp to insert a new point. With the point selected, change the Selected Color to black. Test render. The fluid color tapers from black to gray with the gray in less dense edge areas of the fluid.

The adjusted Color subsection for the fluid shape node.
4주차

5. At this stage, the fluid becomes fairly thin as the dynamite falls. Essentially, the fluid is moving slower than the dynamite bundle. To solve this, you can force the emitter to contribute Velocity values to the container. Switch to the fluidEmitter2 tab. Expand the Emission Speed Attributes section. Change the Speed Method menu from No Emission to Add. The Add option continually adds value with no maximum limit. (In contrast, the Replace option incrementally increases the voxel Velocity values toward a maximum value, which is determined by the fluid shape velocity setting.) Change Inherit Velocity to 6. When the emitter has transform animation, as it does in this case, the emitter velocity is multiplied by the Inherit Velocity and added to the Velocity value passed to the voxels. Play back from frame 1. The fluid becomes thicker as the dynamite falls. Return to the fluidShape3 tab and change Diffusion (in the Density subsection) to 0.2. A higher Diffusion value averages the voxel Density values and creates a softer edge. You can also improve the overall fluid render quality for the container by increasing the Quality value in the Shading Quality section.
The fluid emitter’s adjusted Emission Speed Attributes section.
4주차

Textures
- Texture Color
- Texture Incandescence
- Texture Opacity

Texture Type: Billow
Coordinate Method: Fixed
Coordinate Speed: 0.200

Color Tex Gain: 1.000
Incond Tex Gain: 1.000
Opacity Tex Gain: 1.058

Threshold: 0.207
Amplitude: 0.760
Ratio: 0.707
Frequency Ratio: 2.000
Depth Max: 4
Invert Texture: 
Inflection: 

Texture Time: 4.500
Zoom Factor: 1.000
Frequency: 0.744
Texture Origin X: 0.000
Texture Origin Y: 0.000
Texture Origin Z: 0.000
Texture Scale: 2.000 1.000 1.000
Texture Rotate: 0.000 0.000 0.000
Maya nParticle simulations can create believable bodies of liquid, such as pooled oil or water. In addition, nParticles can recreate airborne particulates, such as rain, snow, ash, sparks, or smoke. You can render nParticles with a wide variety of renderers. In fact, one particle type, Blobby Surface, supports standard Maya materials. It’s not necessary to animate nParticles—you need only generate particles with an emitter and influence their motion with physics-based fields and collision surfaces. Hence, nParticles presents a powerful simulation system appropriate for a wide variety of natural phenomena.

This chapter includes the following critical information:
• Emission and simulation of nParticles
• Application of fields and passive colliders
• Shading of nParticles to emulate water, smoke, and sparks

nDynamics versus Dynamics
Maya offers two dynamic simulation sections: nDynamics and Dynamics. Many of the tools, options, and node attributes within these two sections are similar. For example, the fields available within both sections are essentially the same and the majority of attributes between nParticles and particles are shared. Nevertheless, the nDynamics system take advantage of Nucleus nodes, which drive the physics-based simulation. The Dynamics system is based on an older simulation code and cannot directly interact with Nucleus nodes.
While nDynamics provides a robust means to intermingle n-based systems, such as nParticles, nHair, nMesh, nCloth, and nConstraints, it lacks the active rigid body and Fluid Effects tools of the Dynamics system.
Creating a Liquid Mass with nParticles

Part 1 of Project 2 starts with the addition of liquid flowing down the stairs to the floor. This allows us to cover the basic requirements of nParticle generation: an nParticle emitter and nParticle shape node. In addition, we’ll create collisions with the Create Passive Collider tool.

Setting Up an nParticle Emitter

There are four types of nParticle emitters: 1) a standard emitter which is placed at a particular point in space; 2) a “drawn” emitter that places individual nParticles at particular start positions; 3) a surface emitter that births nParticles at each vertex position; 4) an emitter that automatically fills the volume of a surface. We’ll start with a standard emitter. To add one to Project 2, follow these steps:

1. Open the Project2.1.ma scene file. This is located in the /ProjectFiles/Project2/maFiles/tutorial directory. To avoid missing texture bitmaps, choose File > Set Project and select the /ProjectFiles/Project2/ folder before opening the .ma file.

2. Using WorkCamera, change the view so that you can move around the mechanical animal (we’ll use the Persp camera for rendering). Switch to the nDynamics menu set. Choose nParticles > Create nParticles and change the nParticle preset from Cloud to Water. Choose nParticles > Create nParticles > Create Emitter. An emitter with a circular icon is placed at 0, 0, 0; a Nucleus node, with an N icon, is placed at the same location. To see the emitter more easily, hide the polygon and NURBS surfaces through the view panel’s Show menu.
3. Return to frame 1. Play back the timeline. nParticles are generated in omnidirectional fashion from the emitter but soon fall downwards due to the Nucleus built-in gravity. To create an accurate simulation, you must start the play back at frame 1. In addition, frames should not be skipped. To ensure this, click the Animation Preferences button at the bottom-right of the Maya program window (this is directly to the right of the Auto Keyframe Toggle button and above the Script Editor button); once the Preferences window opens with the Time Slider section visible, set the Playback Speed menu to Play Every Frame.
4. Select the emitter and interactively move it so that it sits in the depression at the top-right of the stairs behind the animal. Return to frame 1 and play back. Feel free to extend the duration of the timeline to better see the simulation. You can place an emitter anywhere in the scene. You can select the emitter node through the Hypergraph or Outliner.
Reviewing nParticle Nodes
Before fine-tuning an nParticle simulation, it pays to review the various nodes of an nParticle system. A basic system is composed of the following nodes: emitter, nParticle transform, nParticle shape, Nucleus, and time. Every Maya scene carries a single time1 node that relates the timeline to any node dependent on the current frame number. As discussed earlier in this chapter, the Nucleus node handles the physics-based simulation of various nDynamics systems. If no Nucleus node exists in the scene, the n-tool creates a nucleus1 node. You have the option to create additional Nucleus nodes at any time. The emitter node combines transform and shape functionality by determining the location of the emitter and the basic emitter qualities, including nParticle directionality, nParticle birth rate, and initial nParticle speed. The nParticle shape node carries attributes that affect nParticle size, render style, lifespan, and total scene count. Note that a single nParticle shape node carries all the nParticles generated by an emitter. The nParticle transform node stores the position of the entire nParticle mass; however, when playback occurs, nParticles are always born at the emitter location.

Time, emitter, nParticle shape, Nucleus, and nParticle transform nodes, as seen in the Hypergraph: Connections window. In addition, the assigned particle material shading group node, ending with SE, is shown.
Adjusting nParticle Attributes
To save time, you can use one of the Create nParticles menu presets to create an nParticle emitter designed for a specific scenario. Aside from Water, there are also Points, Balls, Cloud, and Thick Cloud presets. The following list details important aspects of each preset:

**Points** creates Point nParticles that must be hardware-rendered.
**Balls** produces Blobby Surface nParticles that are strongly affected by Nucleus gravity.
**Cloud** creates Cloud nParticles that ignore Nucleus gravity.
**Thick Cloud** differs from Cloud in that it adds a fluid volume material to the shading network.
**Water** utilizes the Enable Liquid Simulation section of the nParticle shape node, is affected by Nucleus gravity, and is automatically assigned to an npWater material, which is a transparent, reflective, and refractive Blinn.

The presets remotely change the Particle Render Type menu found in the Shading section of the nParticle shape node, as well as various dynamic sections of the same node. The Particle Render Type menu carries ten particle types. Three types support software-rendering: Tube, Cloud, and Blobby Surface (this trait is indicated by the s/w in the menu list). The remaining seven types require hardware rendering, either through the Hardware Render Buffer, the Maya Hardware renderer, or the Maya Hardware 2.0 renderer. To combine hardware-rendered nParticles (or hardware-rendered Dynamics particles) with software-rendered layers, you must use the Render Layer editor or composite separate render passes in an external compositing program.
The ten particle types offered by the Particle Render Type menu in the Shading section of the nParticle shape node. The s/w notation indicates particles that support software rendering.

Note that nParticle presets add a shading network to the scene that includes a surface material, a volume material, and a particleSamplerInfo node. These shading networks are discussed in more detail in the “Adjusting an nParticle Material to Emulate Smoke” section later in this chapter.
You are free to adjust any of the nParticle shape node attributes to customize the simulation. In addition, you can adjust the built-in dynamic attributes of the Nucleus node. To do so for Project 2, follow these steps:

1. In the Particle Size section of the nParticleShape1 node’s Attribute Editor tab, change Radius to 0.2. The nParticles immediately change size in the view panels.

2. Open the nucleus1 node in the Attribute Editor. In the Gravity And Wind section, increase Gravity to 25. Play back from frame 1. The nParticles fall more rapidly.

3. Open the emitter1 node in the Attribute Editor, expand the Basic Emitter Attributes section, and change Rate(Particles/Sec) to 1000. Return to frame 1 and play back the timeline. The number of nParticles is significantly increased. Change the Emitter Type menu to Volume. The emitter icon changes to a cube. You can scale the icon. Play back. The nParticles are born within the space of the volume shape. Scroll down to the Volume Emitter Attributes section. The Volume Shape attribute supports five primitive shapes, which you can change at any time. Return to the Basic Emitter Attributes section and change the Emitter Type back to the default Omni. In the Basic Emission Speed Attributes section, reduce Speed to 0. Play back. The nParticles drop straight down in a line. Speed sets the nParticles’ initial velocity. With Speed set to 0, Nucleus gravity is the only force imparting momentum. Return Speed to 1.0. Altering the Speed allows you to emulate a wide variety of phenomena, from slowing drifting smoke to quickly-moving fireworks.
The Collisions section of the nRigidShape2 node. A similar section is carried by the nParticleShape1 node.
4. By default, the nParticle collision occurs at the outer surface of each nParticle. Hence, the Particles do not penetrate the collision surface (this is a distinct advantage over Dynamics particles). You can offset the collision boundary, however, by adjusting the Thickness attribute of the nRigid shape node. For example, to let the nParticles sink slightly on Project 2, reduce the Thickness value to −0.1 for each nRigid shape node (be careful not to lower the value too far, otherwise, the nParticles will not collide with the surfaces). To display the virtual thickness of the surface, change the Solver Display menu to Collision Thickness. By default, nParticles do not collide with themselves. You can turn on self-collisions by selecting the Self Collide attribute in the Collisions section of the nParticle shape node. Nevertheless, you can leave Self Collide deselected for a water simulation (the goal is to create a cohesive mass of water as the water falls through the virtual air).

A pair of nRigid passive colliders cause the particles to collide with the polygon surfaces. An Incompressibility value of 0.3 and a Friction value of 0.3 allows the particles to spill over the edge but come to a relatively quick stop. The transform handle indicates the location of the emitter.
Controlling nParticles with Expressions

This requires the creation of a new expression through the Expression Editor. While we’re creating this, we’ll discuss the basics of Maya expression execution, including structure, syntax, and evaluation.

An Introduction to Expressions

Expressions are special text instructions that you can apply to node channels. Nodes are discrete units of a hierarchy that store information (such as a transformation matrix, geometry attributes, and so on), while channels are keyable attributes of a node, such as Translate X, Visibility, and so on. The instructions can take the form of mathematical equations, conditional statements, or a linked relationship with a different channel (provided by the same node or a completely different node within the scene).

When an expression is applied to a channel, you cannot keyframe the channel unless you remove the expression. If an expression exists for a particular channel, its numeric cell is colored light purple. You can remove the expression by RMB-clicking over the channel name and choosing Break Connections from the menu. Note that this deletes the entire expression. You can also edit the expression in the Expression Editor to remove the reference to a particular channel. The editor is discussed in the next section.

Working with the Expression Editor

Maya’s Expression Editor offers a means to write, edit, and access expressions within a Maya scene. You can launch the editor by choosing Window > Animation Editors > Expression Editor. If one or more expressions exist within an open scene, you can list them by choosing Select Filter > By Expression Name through the editor’s top menu. To see the contents of a particular expression, click on the expression name in the Expressions field.
The Translate X channel of a polygon sphere indicates an expression with purple coloring.

A scene carries a single expression, expression1. The contents of the expression are revealed in the Expression text field.
You can edit a current expression within the built-in Expression text field at the bottom of the editor. The field supports system cut and paste operations. Once you’ve typed the revisions, you can update the expression by clicking the Edit button at the bottom.

To create a new expression, choose Select Filter > By Expression Name through the Expression Editor menu, empty the Expression text field by clicking the New Expression button, enter a new expression name into the Expression Name field, type one or more lines in the Expression text field, and click the Create button. Maya checks the syntax of the expression at this point; if there is an error, a red line appears in the feedback section of the Command Line at the bottom of the Maya program window with the phrase // Error: Expression invalid after edit. If the expression is valid, the feedback section displays //Result: [expression name].

When applied to geometry, expressions are stored in an expression node, which is connected to the nodes it lists within the expression text. However, if the expression applies to a per-particle attribute, the expression is stored in the particle or nParticle shape node.

Reviewing Basic Expression Syntax

Before writing expressions, it pays to review basic syntax and construction. A few critical areas are discussed here.
End of Line You must end each line of an expression with a semicolon. The exceptions include lines that are commented with a // at the line start and conditional statements, such as if statements (discussed at the end of this section).

Channel Names To refer to a channel, you must also include the node name and a period. For example:

```
pSphere1.translateX
pCube2.rotateY
nurbsCone1.visibility
```

Maya accepts two variations of transform channel names:

```
pSphere1.translateX or pSphere1.tx
pCube2.rotateY or pCube2.ry
```

Spelling and Capitalization Maya is sensitive to spelling and capitalization. Improper spelling or capitalization of node names or channel names makes the expression invalid and no part of the expression will function. You can list the channels that are available to an expression for a particular node by selecting the node and choosing Select Filter > By Object/Attribute Name in the Expression Editor. The node is listed in the Objects field and the channel names are listed in the Attributes field. If you click on one of the channel names, the full node/channel name is listed in the Selected Object And Attribute cell, which you can select, copy, and paste into the Expression text field with operating system shortcuts (such as triple-clicking the name to select and using Ctrl + C and Ctrl + V to copy and paste in Windows).
Equations The channel that is affected by an expression line is always to the left of an equals sign. The right side of the expression line may include a value or some combination of mathematical formulas and other channel names. Here are a few examples:

pSphere1.translateX = 3;
pCube2.translateX = pSphere1.translateX;
pCube2.translateY = pSphere1.translateY+5;

Operators As for mathematical formulas, expressions use the following operators:

+ plus
– minus
/ divide
* Multiply

For more complex mathematical operations, Maya provides a long list of MEL functions that you can access through the Insert Functions menu of the Expression Editor. These are represented with a short name and parentheses where the user inserts one or more values between the parentheses. For example, to raise 2 to the power of 12, choose Insert Functions > Math Functions > pow() and enter 2,12 between the parentheses, producing a section of the expression that reads pow(2,12). Thus, an expression line may look like this:

pSphere1.tx=pow(2,12);
6주차

Note that you can enter a mathematical formula in the Script Editor and thus use it as a command-line calculator. For descriptions of each MEL function, visit the Commands section of the Technical Documentation area of the Maya Help files.

Conditional Statements Expressions support conditional statements that test criteria before executing a specific part of the expression. The most common conditional statement is the if statement. The statement requires the following syntax:

```mel
if (node.channel < n)
execute this line;
```

Hence, a working if statement might be:

```mel
if (pSphere1.ty < 10)
pSphere2.ty=pSphere1.ty;
```

With this example, if the Translate Y value of pSphere1 is less than 10, then pSphere2's Translate Y value is taken from pSphere1. If pSphere1's Translate Y is equal to or greater than 10, then the line after the if line is skipped and pSphere2's Translate Y value is left as is. You can test this expression in a number of different ways by replacing the `<` (less than operator) with these other operators:
> greater than
= = equals
!= does not equal
<= less than or equal
>= greater than or equal

You can test multiple conditions by using &&. For example:

```cpp
if (pSphere1.tx < 10 && pSphere1.ty > 5)
pSphere2.ty = pSphere1.ty;
```

With this example, the second line is only executed if tx < 10 and ty > 5.

Top: Emit From Object creates nParticles along a surface when Emitter Type is set to Surface. Bottom:

nParticles are born in a specific location on the surface with the use of texture emission and black-and-white emission bitmap.

The nParticles have been switched to Blobby Surface.
Simulating a Disintegration Effect

Preparing a Mesh for the Creation of Shards
The Create Shatter tool breaks the surface in a random fashion, using preexisting edges. Each section is referred to as a shard. If the shard count is less than the surface face count, the shards are composed of multiple faces.
You can choose the number of shards when applying the tool. You can also force the shards to be in specific locations by applying the tool to a high-resolution surface. For example, to create numerous, brick-like shards, update the model so that it possesses a large number of quadrilateral faces. You can apply various modeling tools to achieve this, including:

- Interactive Split Tool
- Insert Edge Loop Tool
- Cut Faces Tool
- Add Divisions

These tools are all found within the Edit Mesh menu. You can force the Add Divisions tool to add divisions in the U and V directions by selecting the Linearly radio button in the Add Divisions To Face Options window; you can then set the Divisions In U and Divisions In V slider values. As an example, Figure 9.3 illustrates the result of such modeling.
The TowerWalls and TowerTop surfaces are updated to give them higher resolution while maintaining quadrilateral faces.

The Create Shatter tool requires “clean” surfaces with no errors. In addition, the tool prefers that each surface is assigned to a single material, has a central pivot, and has zeroed-out transforms. To ensure the building surfaces possess these traits, follow these steps:

1. Select the building surfaces and assign them to the default Lambert1 material through the Hypershade window.

2. Center the building surface pivots by choosing Modify > Center Pivot.
3. Choose Modify > Freeze Transformations. The current Translate and Rotate values are set to 0, 0, 0 and the Scale is fixed at 1, 1, 1 for each surface.

4. To remove any unseen errors, such as nonmanifold geometry (edges that are extruded in more than two directions), choose Mesh > Cleanup to launch the Cleanup tool. In the Cleanup Options window, reset the tool by choosing Edit > Reset Settings from the upper-left menu. In the Remove Geometry section, select Lamina Faces, Nonmanifold Geometry, Edges With Zero Length, and Face With Zero Geometry Area. Click the Cleanup button. Any geometry errors that match the selected criteria are removed automatically (these errors are often imperceptible, so there may be no overall change to the surface appearance).

5. As an extra precaution, you can ensure that no unmerged vertices exist on the model by using the Merge tool. To do this, select one surface, such as TowerWalls, RMB-click over the surface in a view panel, and choose Vertex from the marking menu. Select all the vertices on the surface. Choose Edit Mesh > Merge with its default settings. The tool merges vertices that are within 0.01 world units of each other, including those that already overlap but may not be merged. Select the surface as an object. Chose Edit > Delete By Type > History to remove
2. Examine the Hypergraph or Outliner. Each new shard is represented by a polygon node under a WallShatter group node. The original surface is hidden. In a view panel, click on the shattered surface in several places. Select one of the new brick-like shards and temporarily move it away from the wall. Note that the shards meet at their edges.

3. Select the TowerTop surface. Choose Effects > Create Shatter > . In the Create Shatter Effect Options window, switch to the Surface Shatter tab.
A brick-like shard is temporarily moved away from the shattered wall. The wall now attains thickness.

Enter RoofShatter into the Surface Shatter Name cell. Change Shard Count to 1024. This will produce larger shards on the roof. Set Extrude Shards to –0.5. A smaller Extrude Shards value prevents the roof from intersecting itself at the edges. Leave Post Operation set to Shapes. Deselect Triangulate Surface and Smooth Shards. Click the Hide radio button beside Original Surface. Click the Create button. The TowerTop surface is shattered and gains thickness.

Shards at the front corner are selected. These shards will remain intact for dynamic simulation.
Exploding Shards with Fields
The goal for Project 4 is to create a blast at the top of the tower that causes the corner bricks to scatter outwards. As such, you can add a Radial field to push the shards. You can follow these steps:

1. Select all of the nCloth nodes. To save time during future steps, you can turn the nodes into a quick select set. To do so, choose Create > Sets > Quick Select Set with the nodes selected. In the Quick Select Set option window, enter a name, such as nClothNodes, into the Name cell and click OK. At that point, you can select all the nCloth nodes by choosing Edit > Quick Select Sets > set name. With the nCloth nodes selected, choose Fields > Radial. Interactively move the radialField1 icon and place it at the base of the shards, close to the corner facing the camera.
(roughly −6, 16, −2 in XYZ). Increase the new radialField1 node’s Magnitude to 12. Reduce Attenuation to 0.3 and increase Max Distance (in the Distance section) to 150 to lengthen the field falloff area. Temporarily shorten the timeline to 20 frames. Create a Playblast from the Persp view so that you can view a wide area of the scene. You can unhide Building-Base and Unbroken Tower as reference. The shards explode outwards in a spherical fashion. To increase the speed to the shards, increase the radialField1 Magnitude. To slow the shards, reduce the Magnitude. Note that the nucleus1 Gravity still affects the shards. Open the nucleus1 node in the Attribute Editor. Increase the Gravity to 250.

The shards are blown outward with the addition of a Radial field. In this case, green shards originate from the roof and white shards originate from the walls. Some of the larger shards stretch and deform.

2. To delay the explosion, you can animate the Magnitude attributes of the fields. Return the timeline to its full length of 60 frames. Go to frame 40. Keyframe the Magnitude for the radialField1 node at its present values. Keyframe the nucleus1 node’s Gravity at its present value. Go to frame 39. Keyframe the Magnitude for the radialField1 at 0. Keyframe the nucleus1 node’s Gravity value at 0. Create a Playblast. The shards begin moving on frame 40.
VFX Notes: Determining the Speed of Debris

One challenge when creating an explosion is determining the speed that debris should travel through the air. Large-scale objects fall more slowly when compared to small-scale objects. For example, large stones exploding from a volcano take longer to reach the ground than sand tossed onto a tabletop. When shooting miniatures with film or video, you can apply a formula to determine an appropriate frame rate to make the miniature object fall at the correct speed (square root of the scale multiplied by the base frame rate, which leads to some form of high frame rate/slow motion).

However, when setting up a 3D scene, a frame rate change does not suffice because the dynamic simulation is a simplified version of the real world and the speed that the 3D objects are traveling may be incorrect. As such, the best solution is to compare the simulation to film or video of similar real-world events and make simulation adjustments to match the qualities.

That said, it may be mathematically possible to determine the values supplied to fields and other components of a dynamic simulation. However, the math would be complex and require such information as explosive velocity (which varies with the explosive material involved).

Note that the 9.8 value assigned to various Gravity attributes in Maya is based on standard gravity, which is the gravitational acceleration of an object in a vacuum near the Earth’s surface (9.80665 meters/second^2).
Adjusting nCloth Attributes to Emulate Bricks

By default, nCloth surfaces deform as they are subjected to Nucleus gravity and other assigned fields. In the case of Project 4, this causes large shards, such as those along the roof, to twist as they explode outwards. Although this may be acceptable, you have the option to make the nCloth bodies more rigid. To do so, you can adjust the attributes listed in Table 9.1 for the nCloth nodes through the Channel Box.

**Stretch Resistance:** The amount of resistance under tension. The higher the values, the stiffer the surface but the more expensive the computation.

**Compression Resistance:** As a rough rule of thumb, keep the Compression Resistance lower than the Stretch Resistance to avoid folding.

**Bend Resistance:** The amount that the surface resists bending when under strain.

**Rigidity:** How inclined the mesh is to be a rigid body. This is 0 by default.

**Deform Resistance:** How much a mesh is attracted to its current shape. This is 0 by default.
nParticles are born at the nCloth object locations over time, producing trailing columns.

A 3D fluid container is scaled and placed at the top of the tower.
Left to Right: Detail of depth pass, diffuseMaterialColor pass, MasterBeauty pass, and mv2DNorm- Remap motion vector pass.
The Primary Visibility of all of the shards is turned off through the Attribute Spread Sheet.
A detail of the rendered shadows render layer.
Detail of nClothShardsBump layer, where the shards are given a material override. The override assigns a bumpy gray Blinn to the surfaces. The render will be used during the compositing phase to reduce the apparent smoothness of the shards.
Simulating a Shattering Light Bulb

Explosions in film and television are highly theatrical. Fire and explosives are filmed at high speeds to slow them down, amplifying their visual impact. Most of all, pyrotechnics are well thought out, carefully staged, and anything but spontaneous. A big part of pyrotechnics is the setup. This involves making sure the explosives are in the right spot, taking objects and prescoring them so they break apart in an expected manner, and so on. Pyrotechnics in 3D are no different. The same time and thought must be put into the scene in order to get the desired results. The next project involves blowing up a gas station.
Project: Shock Wave
The first part of destroying the gas station is blowing out the glass from the doors and windows. The concept is that the explosion sends out a shock wave strong enough to destroy the glass of the building. Converting the glass geometry to nCloth and then adding a Tearable Surface constraint leaves the geometry at the mercy of any fields you apply.

1. Load the scene gasStation1.ma. The scene contains a modeled gas station with all its parts ready for devastation. The fluid explosion from the first project of this chapter is also included and hidden on a layer. It has been disabled and won’t need to be activated until the next project.
2. Select the glass node. Choose nMesh ➔ Create nCloth. Dimensions within the scene are close enough to being metric that you can leave the Solver Scale set to 1.
3. Reselect the glass node and choose nConstraint ➔ Tearable Surface.
4. Change the Glue Strength on the Tearable Surface node to 0.0. Without any Glue Strength, the shards of glass will fly out easily.
5. Select the glass node again and add an Air field, using the Wind settings.
6. Key the Air field’s Magnitude by using the settings from Figure 7.38.
7. Set the Attenuation to 0 and turn off the Max Distance. With both the Attenuation and Max Distance off, the force of the air field will mimic an exploding force.
8. Change the Direction to 1 in the Z axis. Figure 7.39 shows the simulation at frame 10.
9. The air field provides the exploding force but will only push the glass out. It does not cause the shards to tumble in midair. Add a Turbulence field to the glass to enhance the effect.
10. Key the Turbulence field’s Magnitude by using the settings from Figure 7.40.

11. Change the Turbulence Frequency to 5, forcing the pieces of the glass node to tumble more frequently. Also set the Attenuation to 0, just as you did for the Air field. Figure 7.41 shows the progress so far.
12. The last step is to turn on Use Plane on the Nucleus node to prevent the pieces of glass from falling endlessly. Adding Friction and Bounce to the plane keeps the glass shards from sliding too much. Use Figure 7.42 for the settings.
Create a container and emitter.

The Density parameters

The Turbulence settings

The low resolution of the container was fine for establishing the fluid’s motion, but as we add more detail, we need to increase it.
As noted earlier, a flame is actually glowing soot. When all the energy escapes the particles, the only thing left is black dust. Using this information, make the color of the fire black, representing the extinguished soot. This serves another purpose as well. Although a simple change, it is an important one. The black provides the color of soot, which is also the smoke. The effects of this will become clearer after the next step. Shows the progress so far. It is a render of frame 150.

The intense orange color values

The Incandescence graph
The flame looks too thin. It lacks substance. By default the opacity is consistent throughout the fluid.

Rendering the fire again at frame 150 reveals a much improved flame.
Now you can refine the reaction between temperature and fuel. The first step is to make sure enough fuel and temperature are being emitted into the container. Select the emitter. Increase the heat and fuel emissions to 2 and 4, respectively. Maintaining the delicate balance between fuel and heat is usually done best with a 2:1 mixture, two parts fuel to one part temperature.

Increase the heat and fuel emissions.
The flame is close to what we want, but it lacks that internal turbulence. This isn’t a result of the Turbulence value being too low; it stems from a poor reaction between the fuel and temperature. Several attributes need to be changed to get the right reaction. First, change the Temperature Scale to 1.6. Increasing this makes the fire hotter, which visually adds more incandescence to the flame. Next, set the Buoyancy to 10. This makes the temperature rise a little more slowly than the density. In real-world terms, this helps make the smoke rise above the flames. The last temperature setting, Dissipation, makes the temperature die out; the higher the dissipation, the faster the flames die.
Creative Realistic Fire and Sparks
10주차
Creating Explosion

Exploding a Fireball with Static 3D Fluid

By default, Fluid Effects containers create dynamic fluid simulations where voxels change property values over time. As an alternative, however, you can create a static fluid mass and animate shading and texturing properties to create the illusion of motion.

Creating a Static Fluid Mass

As Part 5 of Project 3, we'll create a fireball (as if the dynamite detonated). You can follow these steps:

1. Choose Fluid Effects > Create 3D Container. Interactively move and scale the container so that it rests on top of the foreground rock. An exact position and scale is not critical at this point. Feel free to temporarily hide geometry and other containers to make the adjustment easier.

2. Open the new fluidShape4 Attribute Editor tab. At the top of the tab, select Disable Evaluation. This makes the fluid static and non-dynamic. In the Container Properties section, deselect Keep Voxels Square. This reveals the Resolution X, Y, Z cells. You can enter different voxel sizes for each local axis. For the moment, enter 40, 40, 40.
3. In the Contents Method section, change the Density menu to Gradient. This reveals the Density Gradient menu. Change the menu to Center Gradient. This fills the container with fluid with the highest density values in the container volumetric center. Change The Velocity menu to Off(Zero). Because the container is no longer dynamic, Velocity values are no longer needed.

4. In the Shading section, alter the Edge Dropoff value. Note how different values erode the edge of the fluid mass. Change the Dropoff Shape menu to Sphere. The mass becomes more spherical (Figure 6.17). However, the mass has a very smooth edge. To make the edge more erratic, you can map a 3D texture to the Edge Dropoff. To do so, click the checkered Map button beside Edge Dropoff and select the Volume Noise texture. In the new volumeNoise tab (named volumeNoise2 in the example files), change the Frequency to 5 to scale down the noise pattern. Set Noise Type to Perlin Noise. The addition of the texture will not be visible in the view panels. Test render. The edge of the mass becomes irregular (Figure 6.18). If any of the edges of the noise pattern appear compressed or vertically stretched, rotate the container so that one side is flat to the camera and test render again.
FIG 6.17 A new container is placed above the rock. The Density Gradient is set to Center Gradient. The Dropoff Shape is set to Sphere, creating a spherical fluid mass.

FIG 6.18 An irregular edge is created by mapping a Volume Noise texture to the Edge Dropoff.
5. By default, the fluid mass is colored white. However, you can base the color on different property values, such as Density or Temperature, or through various gradients. Return to the fluidShape4 tab and expand the Shading section and Color subsection. In the Color subsection, change the Color Input menu to Center Gradient. This relates the graph ramp to the distance from the container volumetric center. That is, fluid close to the center receives color from the right side of the ramp while fluid at the outer edges of the fluid dropoff edge receives colors from the left side of the ramp.

Insert four new points into the Color ramp with positions roughly at 0.15, 0.3, 0.5, and 1.0. Change the colors of the points (going left to right) to medium gray, dark gray, orange, yellow, and white (Figure 6.19). Change the Interpolation menu for each point to Smooth. Test render. The fluid takes on different colors. You can offset the Color graph ramp and therefore have the fluid mass “slide” through the various colors by changing the ramp’s Input Bias value. For example, changing Input Bias to −0.4 causes the fluid to take on more colors from the left side of the ramp (Figure 6.20).

FIG 6.19 The adjusted Color subsection.

FIG 6.20 The resulting render with Input Bias set to −0.4.
6. Expand the Incandescence subsection. Change the Incandescence Input menu to Center Gradient. Add a new point to the ramp. Adjust the points so that they fall at 0, 0.15, 0.3, and 0.6. Change the colors for the points (going left to right) to black, dark gray, orange, and light yellow (Figure 6.21). Change the Interpolation menu for each point to Smooth. Set Input Bias to −0.2. Test render. The fluid colors become more intense.

7. You can add additional irregularity to the fluid edges by adjusting the Opacity subsection graph ramp. In fact, you can use the ramp to selectively display different regions of the fluid. To do so, change the Opacity Input menu to Center Gradient. Alter the ramp so that it forms three peaks (Figure 6.22). This causes the fluid mass to become thin at different depths, forcing the overall mass to have less fluid (Figure 6.23). The left side of the ramp corresponds to the outer edge of the fluid while the right side of the ramp corresponds to the center of the fluid. (If Color Input is set to another gradient type, such as Gradient Y, the left side of the ramp corresponds to the top of the gradient.) Remove the extra points from the ramp and return it to its initial state (a left to right slope up). Test render. The fluid regains its solidity.
Texturing Fluid Color, Incandescence, and Opacity
At this stage of Part 5 of Project 3, the fluid remains fairly consistent in terms of detail and smoothness. You can impose additional variation through the fluidShape4 node's Textures section. Expand the Textures section and select Texture Color, Texture Incandescence, and Texture Opacity. This multiplies each voxel's color, incandescence, and opacity value by the values provided by a built-in 3D noise texture. Use Table 6.1 to alter the noise attributes with the listed values.
Test render. The fluid becomes more complex (Figure 6.24). Experiment with different Color Input Bias and Incandescence Input Bias values, as well as altering the colors in the Color and Incandescence graph ramps. For example, for Figure 6.24 Color Input Bias is set to −0.4 and Incandescence Input Bias is set to −0.1; in addition, the colors for both graph ramps are darkened and fine-tuned.

**TABLE 6.1**

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Value</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color Tex Gain</td>
<td>0.6</td>
<td>The Tex Gain attributes serve as multipliers for noise values, which in turn are multiplied by the voxel color, incandescence, and opacity values.</td>
</tr>
<tr>
<td>Incand Tex Gain</td>
<td>0.7</td>
<td></td>
</tr>
<tr>
<td>Opacity Tex Gain</td>
<td>0.4</td>
<td></td>
</tr>
<tr>
<td>Threshold</td>
<td>0</td>
<td>The greater the difference between Threshold and Amplitude, the greater the contrast within the noise pattern.</td>
</tr>
<tr>
<td>Amplitude</td>
<td>3</td>
<td></td>
</tr>
<tr>
<td>Frequency</td>
<td>2.5</td>
<td>The larger the Frequency value, the smaller the noise &quot;grains.&quot;</td>
</tr>
</tbody>
</table>

FIG 6.24 The built-in noise texture, available through the fluid shape Textures section, adds complexity to the fluid.
12주차 Simulating a Burning Tree

[Image of software interface with highlighted settings]

- Shading:
  - Transparency
  - Glow Intensity: 0.000
  - Dropoff Shape: Z Gradient
  - Edge Dropoff: 0.306

- Color:
  - Selected Position: 0.000
  - Selected Color
  - Interpolation: Linear
  - Color Input: Density
  - Input Bias: 0.000

- Incandescence:
  - Selected Position: 0.000
  - Selected Color
  - Interpolation: Linear
  - Incandescence Input: Density
  - Input Bias: -0.532

- Lighting:
  - Shadow Opacity: 0.322
  - Shadow Diffusion: 0.000
  - Light Type: Directional
  - Light Brightness: 1.000
  - Light Color
  - Ambient Brightness: 0.000
  - Ambient Diffusion: 2.000
  - Ambient Color
  - Directional Light: 0.500
  - Point Light: 0.000
  - Point Light Decay: Linear
  - Real Lights
12주차
12주차
12주차

Strength
- frequency: 0.2
- speed: 0.2

Frequency
- strength: 0.1
- speed: 0.2

Speed
- strength: 0.1
- frequency: 0.2

Fluid turbulence
- 0.2
- 0.4
- 0.6
- 0.8
- 1.0
12주차
12주차
12주차
12주차
12주차
A tornado stretches, most commonly, from cumulonimbus thunderstorm clouds to the surface of the earth. Like all acts of nature, a tornado takes many shapes and sizes, but nothing is more iconic than the funnel cloud. Shows an F5 tornado that touched down in Canada in 2007.

Tornadoes begin with winds spinning horizontally in the lower atmosphere of a thunderstorm. Rising warm air—an updraft—tilts the spinning air vertically. This creates an area several miles wide called a rotating wall cloud. It is within this wall cloud that a tornado will touch down.

A tornado is just spinning air. It rotates counterclockwise in the northern hemisphere and clockwise in the southern hemisphere. If it wasn’t for water vapor and debris, you would never see one. Tornadoes can spin at speeds in excess of 200 miles per hour. They are most recognizably measured by the recently enhanced Fujita scale, where EF0 tornadoes are the weakest and EF5 the strongest. A major component in a tornado is its helicity, the amount of corkscrew-type motion it has. The winds spin, but they also travel upward, creating this spiraling effect. Replicating the look of a tornado in Maya is all about speed. It is a delicate balance between upward motion and spinning motion. When the two are out of sync, the funnel cloud falls apart. When you don’t have enough upward momentum, the tornado spins itself out of control. Too much upward motion, and the fluid is expelled from the container.
Project: Funnel Cloud
The first project is to create a basic funnel cloud. You will build the effect from scratch by using Maya fluids and a Volume Axis field. The purpose of this exercise is to learn how to spin a fluid. The look of the cloud is addressed, but refining it is for another project. Our focus is to establish the motion and not the look. There is no scene to start from; you will create the fluid from scratch.

1. Create a 3D container by using the settings shown in Figure
2. Create a primitive NURBS torus by using the defaults. Use Figure to transform it to the bottom of the fluid.

Add the torus as an emitter to the fluid. You can use the defaults or optimize it by emitting only density. Run the simulation to see the progress so far. Figure illustrates frame 150.
3. To get the rising fluid to twist and spin, use a Volume Axis field. A cone is used for the field’s shape. The conical shape is used over a cylinder to allow the fluid to have more freedom of movement and to produce a stronger vacuum force within the fluid container. Figure shows the settings for its creation.

The torus is made into an emitter and tested.

The settings for creating a Volume Axis field
Turning on the High Detail Solve option allows the fluid to rotate or twist.

Display the velocity vectors to understand the motion path of the fluid.

The velocity vectors are pushing the tornado upward.
(a) A funnel cloud forms by frame 50;  
(b) the funnel cloud at frame 96.

Translate and scale the volume axis field.
The funnel cloud is the full height of the container.

The funnel cloud falls down at frame 110 and never regains its shape.

The colors used for the funnel cloud
Add Turbulence to the Volume Axis field to give the funnel cloud a natural shape.

The settings for creating the container

Create a lofted surface by using the default options.
13주차

Place an emitter at the bottom of the container.

Add a Volume Curve field.
Shape the funnel cloud with the Curve Radius graph.

Use Along Axis and Around Axis to put the tornado in motion.

The color settings for the color graph

Change the boundaries and turn on High Detail Solve for All Grids.
13주차

The progress of the tornado so far

The simulation at frame 100
The simulation at frame 100 with swirl and turbulence added

The new Density parameters

The tornado with (a) an XYZ resolution of 40, 60, and 40; (b) an XYZ resolution of 60, 90, and 60
Create a 3D container.

Duplicate the `twisterSurface` node.

Create a Cylinder Volume Axis field.

Transform the Cylinder Volume Axis field.
The dust cloud at frame 105 with the Volume Axis Field.

Set the values for the debrisFountain fluid.

The colors for the dust cloud
The settings for the Transparency Dropoff

The dust cloud at frame 100 with self-shadowing turned on

Texture the Opacity to give the dust cloud detail.

The textured fluid at frame 100
14주차

Rebuild twisterCurve.

Assigning a new hair system to the twister curve results in these nodes.

Use the Connection Editor to change the field’s input curve.
Create two Hair Transform constraints. Snap one to the top of the curve and the other to the bottom.

The twister’s Volume Curve field is manipulated by the Hair Transform constraints.
The hierarchies used to control the twister

The Shading Quality settings for both fluids

Add a Tangent constraint to debrisFountainVolume–AxisField.
The simulation (a) as seen in the viewport and (b) rendered with Mental Ray or Arnold
F5_1.ma is set up with an environment and tornado.

The Sculpt Deformer settings

The settings for creating nParticles
The settings for creating a Volume Axis field.

Translate and scale the Volume Axis field.

The nParticles at frame 46.
Add a Transform constraint to the cabin.

The values for the nCloth cabin
The settings for nucleus Scale Attributes

<table>
<thead>
<tr>
<th>Scale Attributes</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Time Scale</td>
<td>1.000</td>
</tr>
<tr>
<td>Space Scale</td>
<td>0.304</td>
</tr>
</tbody>
</table>

The settings for Wind Field Generation

<table>
<thead>
<tr>
<th>Wind Field Generation</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Air Push Distance</td>
<td>100.000</td>
</tr>
<tr>
<td>Air Push Vorticity</td>
<td>4.000</td>
</tr>
<tr>
<td>Wind Shadow Distance</td>
<td>0.000</td>
</tr>
<tr>
<td>Wind Shadow Diffusion</td>
<td>0.000</td>
</tr>
<tr>
<td>Wind Self Shadow</td>
<td></td>
</tr>
</tbody>
</table>
The nParticle wind begins to rip the cabin apart.

The settings for caching the nCloth cabin

The settings for caching the fluid tornado

The scene rendered with the default Physical Sky settings
The settings for the mia_exposure_simple1 node

The scene rendered with the gamma turned down
The settings for the Physical Sky node

The scene rendered with haze and a bluish tint

The scene rendered with a sun angle for dusk
This first section presents a survey of possible workflows for grooming hair with xGen. Extremely helpful in this regard are the many xGen videos by Autodesk, both in the Maya Mondays series, as well as the Maya Learning Channel. So in addition to the videos embedded below, be sure to check out these playlists as well. Finally, although not covered here, this video by Steven Roselle gives a great intro to working with archives.

**Table of Contents**

A. Spline Guide Methods

1. Tube Method
2. Strait-Ahead Method
B. Groomable Method

Let's begin with the initial creation of an Xgen description:
15주차

Create XGen Description

1. New Description Name: MeryHair

2. Each Description must be stored in a Collection
   - Add Description to existing Collection: Livingroom
   - Create new Collection named: collection3

3. What kind of Primitives are made by this Description?
   - Splines (use for long hair, vines, etc)
   - Groomable splines (use for short hair, fur, grass, etc)
   - Custom Geometry/Archives (use for any model you have created)
   - Spheres (use for pebbles, marbles, or other round objects)
   - Cards (use for scales or other flat textures)

4. Generate the Primitives:
   - Randomly across the surface
   - In Uniform rows and columns
   - At points you specify

5. Control the Primitives by:
   - Placing and shaping Guides
     - Using Attributes controlled by expressions
     - Using Grooming tools

[Create] [Cancel]
Annotations:
1. The description (1) is the name of what you are making (in this example "Mery's Hair" and in contained in a collection (2). Note that xGen is very pedantic about naming and it is quite an ordeal to rename an xGen stuff. Most important are the names of the collection and the name of geometry you bind to. You will want these to have unique names. For example, ones that include the name of the asset like "MeryScalpGeo" rather than just "scalpGeo".

2. In order to add the description to an existing collection, the collection must be present in the Maya scene. Otherwise this option is greyed out.

3. Here we pick "splines" which will allow us to use curves as guides for the hair groom. As stated in the above pic, this is best for most hair styles. For buzz cuts, beard stubble, eyebrows, and fur the "groomable splines" option is recommended, although as we will see below (section I.B) splines often work better for this too.

4. We want to spread the primitives "randomly across the surface" the way that hair grows evenly from the scalp.

5. Finally, we want to control the hair primitives by "placing and shaping guides". Note that it is also possible to control the description using both guides and expressions. To do this pick "using attributes controlled by expressions" and then after setting up your expressions, change the "control using" to "guides" and add guides. This will create the xGen description, but we will not see any hair primitives until we have placed some guides. Here we need a strategy:

This will create the xGen description, but we will not see any hair primitives until we have placed some guides. Here we need a strategy:
A. Spline Methods

**Spoiler Alert** In the following section I will discuss various approaches to approaching hair grooms, and in the end conclude that a spline based method (the "strait-ahead method described below) is best, even for short hair. I would not recommend using the "groomable splines" method, and the tube method is often too complex.

1. Tube method

One method is Disney's tube method. This requires a fairly complex model which defines hair clumps. The geo tubes are then used to generate hair clumps. The workflow is illustrated here:
2. Strait-Ahead method
While the above method affords a great deal of control and art direction, in many cases a more strait ahead approach is more manageable. The key here is to have a plan, beginning with concept art for the hair style, real-world research, and the final implementation:

(image credit: Shed blog)
Topics covered:
creating guides:
  • rebuilding a normalizing curves buttons
  • copy & paste curve utilities
primitive tab:
  • modifier CV count (for resolution)
  • increase primitive density
  • setting primitive width, taper, etc.
adding details:
  • region maps & masks
  • clump, noise, cut, noise, and curl modifiers
  • expressions (randomizing)

Paint Effects
Because curves and can easily be converted to guides in the utilities, one can use paint effects to create things like braids, convert these to curves (modify > PFX to curves) to generate guides for braids. In this video, Paint Effects is used to draw lines on a polygon model of hair. This is then converted to curves, and then to xGen guides. The basic idea here is that there are lots of ways to create curves (Fiber mesh in Zbrush, Xgen Groomable splines, and xGen interactive grooming introduced in Maya 2017, etc). These curves can then be converted to guides which drive your xGen groom.
B. Groomable Method
Groomable Splines use brushes to "comb" the hair. These brushes create PTEX maps which replace the sliders in the primitive section. The initial creation of Groomable Splines is simple: Select "groomable splines" in the xGen Create Description window, and all other options are greyed out.

Beards and Stubble

1. Begin with a clean scene. When using geo from Maya 2013 & earlier, xGen fails to create the groom PTX maps when creating the xGen description. To solve this, import the geo as an FBX into a new scene in Maya 2015.

2. Select faces (tip: selecting faces in the UV texture editor)
3. Make a selection set (create > Sets > set > options) and name it "stubbleSet"
4. With the faces selected, create a new description.
5. Increase the groom and primitive density as desired. (Note: if you display the grooms as cards instead of lines you can see the width)
6. Add a density mask in the Primitive Generator section. Name it "density" and give it map resolution of 15 TPF (texels per face). We will paint black for the stubble and white for clean skin, and then use an expression to reverse the map (since white=1 and black=0 density). You could alternately use a map created in a 3D paint package (see importing maps). It's important to note that the brush tip needs to be hard rather than feathered as the feathered brush never paints fully black and will thus leave stray hairs.
7. Save the map and open the expression editor. Add the following line (indicated in bold) into the expression:

```
$a=map('${DESC}/paintmaps/stubbleDensity');#3dpaint,15.0
$a = 1.0 - $a;
```

To shorten hair, use the Length brush with the goal set lower (0.1) and a negative increment (-0.1). You can also use this method to effectively remove the guides (setting their length to zero) to match with your density map.

As you comb the stubble/fur with the Pose brush a common problem is that the hair becomes buried under the skin, creating bald spots.
This can be addressed with the *Elevation* brush, however, in many cases it is easier to work with spline guides instead, even when working on short hair and stubble. In the case of beard stubble, you can paint a map to control the density and length, as described above, allowing us to achieve both short and long hair in a single description.

Working with splines allows us to get curved hair (groomable guides can bend but not curve), and do so with only a few guide splines,
A. Exporting xGen files
The two ways to do this in xgen are by exporting the collection or description. Exporting a collection includes spline guides. A description does not, and so the guides must be exported additionally as curves, and then converted back to guides. Further, to import a description into a collection, that collection must be present in the Maya scene. From this we derive the two following workflows:

1. Export Collection (simple)
   1. From the xGen window choose xgen > Export collections or descriptions. Then export the collection (.xgen)
   Done! (Note that when working with groomable splines for fur you would also need to export the groom from the Xgen Window file menu (file > export grooming)

2. Export Description (complex)
   1. Save the spline guides as curves: Modifier tab: select bottom modifier stack (clumping1), click Export guides. This creates a "curves" folder containing a mel file in the collections folder. This mel file can later be opened and run in the Script Editor when importing.
   Alternately, you can use the xGen Utilities Tab to convert the guides to curves and export them as FBX or MA.
   2. Save the description or collection: xgen > Export collections or descriptions exporting the description (xdsc).
   3. Delete the description in the outliner, keeping empty collection, then "save-as" the file to import the description into.
   (As noted above, if working with groomable splines for fur you would also need to export the groom)

3. Saving Modifiers
   Right-click on a modifier and save it as a .xgfx file. Alternatively you can click the little "open folder" button in the modifier toolbar (top right of the tab).
15주차

B. Importing xGen files
The trick here is to keep the description name the same so that the ptex maps connect. To work with Maya, IFF maps are painted onto the geometry that xGen grows out of, and applied to the geo using custom attributes. When the name of the collection or description is changed, these attributes no longer match and must be re-created manually, which is possible but tedious. Therefore, when possible it is desirable to keep the names of the xGen collection and description the same as in the original export.

1. Import a Description (overwriting)
Xgen is very particular about names, so if you are importing and wish to keep the same name (which is desirable), xgen will want to instead create a new description name. To get around this,
   1. Temporarily rename the description folder (ex: descriptionName-tmp).
   2. In Maya, select the scalp geo, and import the xGen description.
   3. Convert the curves to guides (xGen utilities tab)
   4. Delete the new description folder, and rename the original description folder back to its original name
   5. Save the Maya file, and re-open it. The maps will now read in.

2. Import a Collection (overwriting)
   1. Select the geo, import collection, choose "overwrite"
Done! Since the maps are already in the folders on disc, the description, guides, and all the ptex maps read in perfectly.
3. Import a Collection (new collection)
   1. In a text editor, edit the xGen file (.xgen) and change the names as desired. To change the collection name, edit the name and xgDataPath in the palette section. To change the description, edit both the Description: name and the patches token with the same name (just do a search for the description's name in your text editor).
   2. Create directories for this collection & description, copying the subdirectories and ptex map files into it from the old collection.
   3. In Maya select the geo, import collection, choose "overwrite".

4. Reconnecting Ptex Maps
   In the above workflows the maps will read in automatically. However if you wish to edit them further you will need to re-connect the IFF maps if the collection or description names have changed. The issue here is that xgen creates extra attributes on the scalp geo based on the collection and description name which have IFF maps connected to the geo.

3. Import a Collection (new collection)
   1. In a text editor, edit the xGen file (.xgen) and change the names as desired. To change the collection name, edit the name and xgDataPath in the palette section. To change the description, edit both the Description: name and the patches token with the same name (just do a search for the description's name in your text editor).
   2. Create directories for this collection & description, copying the subdirectories and ptex map files into it from the old collection.
   3. In Maya select the geo, import collection, choose "overwrite".

4. Reconnecting Ptex Maps
   In the above workflows the maps will read in automatically. However if you wish to edit them further you will need to re-connect the IFF maps if the collection or description names have changed. The issue here is that xgen creates extra attributes on the scalp geo based on the collection and description name which have IFF maps connected to the geo.
C. xGen Directory Structure and Files Locations
The majority of xGen files are located in the xgen folder of the Maya project. This is defined by the system environment variable $XGEN_ROOT which you can query with the following mel command:
getenv "XGEN_ROOT"; The two exceptions for this are the .xgen and .abc files that are used for batch rendering. These are instead located in the same directory as the Maya scene. If desired this path can be modified in the .ma file with a text editor.

Animation Workflow (Simple)
Turntables
In this workflow the basic idea is that the scalp geo is animated, and the hair just follows. For a shot with an Alembic cache this is very straightforward. When doing a turntable it is a bit more complex since xgen hair does not update when the parent of a geo is moved and only when the geo itself is. Therefore the scalp geo needs to be rotated in the turntable directly, for example by parent constraining the geo to a rotating group, or by skinning the geo to a rotating joint. In the turntables we use, the geo is parented under a locator that is parent-constrained to the rotating curve so it should follow the turntable animation correctly.
Note that when batch rendering turntables (as with all batch renders for xGen you will need to export the patches for batch render with xgen>file>export patches for batch render. This is described in more detail in the Shot Animation section below.
Shot animation
Import the Alembic cache for the geo, the xgen hair automatically follows. This will work inside of Maya. To render it, we need a second step:
Use xgen>file>export patches for batch render. This will write an Alembic cache for the scalp geo to disc, which is kind of redundant since we already have an Alembic cache, but a necessary step for batch rendering to work with xGen. The file is saved to the project's scene folder and uses the following file naming conventions: __.abc.

Notes:
- Translate is locked in the scalp geo when an abc is imported. So once the cache is applied you can no longer move it (unless you disconnect the cache)
- If you translate geo manually you need to refresh the primitives
- Scalp geo must be parent constrained directly in rig, not under a parent. Otherwise the xGen will not update it's location on the timeline properly.

B. Animation Workflow (Complex)
1. Exporting curves for animation
In this step we need to create curves from the xGen guides that we can pass to rigging in order to animate the hair.
- In the utilities tab convert the guides to curves (keeping the guides)
- Rename the curves with modify > prefix hierarchy names. This will add the character's name to all the curves which Alembic likes (ex: Mery_xGenCurve2 etc.)
- Export these curves as .ma or FBX. Suggested naming convention: FileName_nCurves.ma. (see the naming conventions doc for more details).
Alternative method (this is more involved, so only use this method if the above does not work):
1. In primitives tab, check "use animation" and click the "create hair system" button
2. Select the curves in the model view and group them (so they are not nested under the follicles)
3. Parent curves under character's name group, rename the curves with modify > prefix hierarchy names
Export these curves (not the output curves) as .ma (open it to make sure nothing else was exported)

2. Setting up the Rig
Import the curves into the rig file. Make sure to remove any namespaces (with the namespace editor) when importing, otherwise you will get name clashes and your cache will not work. Here we see an example of a rig setup:
15주차

(rig file from the Mery Project)

Above we can see that the rig file has a simple mesh for the hair that the animators can see. This is rigged with FK joints for keyframe animation. The hair mesh is then wrap deformed to the curves which we exported from the groom file (III.B.1 above). As noted above (III.A.notes) the scalp geo must be directly skinned or constrained to rig, not its parent.

3. Populating the character into the scene (importing Maya files with xGen descriptions)
Xgen gets lost when imported due to namespaces. For this reason xGen does not work with referencing since namespaces cannot be removed from referenced objects. They can however be removed from an import:
1. Import the character into the environment file (file>import) with the option "Merge into selected namespace and rename incoming objects that match" selected. With the "root" namespace selected. The file will import in without any namespaces so the maps will work, but you wont see xGen yet.
2. Save and re-open scene, and xGen will appear

4. Exporting/Importing ABC for xGen
Exporting the Alembic cache (from animation):

Export curves to ABC (strip namespaces, world space, HDF5). Curves must be individually selected, not the group. Note that we use HDF5 because we observed errors using the newer Ogawa format both in Maya 2014 and 2015.
Export the geo to ABC (strip namespaces, world space, UV write). The group can be selected for geo.
Importing ABC (to lighting)

Note that in a normal production pipeline the character file would be populated into the environment (as described above in III.B.3) and the animation caches applied there.

Note also that the following covers the process of importing the Alembic curves to drive xGen hair. In a shot if the geo is animated with Alembic caches these would also need to be imported. See the doc FG: Shot Setup for Alembic Caches for details.

- Import the Alembic curves: In the xGen Primitives tab, Guide Animation section, check "Use animation" and uncheck "live mode" and load the curve ABC cache file.
- Prep for batch render: Run `xgen > export patches for batch render` on scalp geo for batch rendering.
- Confirm that an .abc file was written to the project scene directory.

5. Baking Modifiers

We can also bake the modifiers to an XPD file to make the scene render faster.

- In the modifiers section create a GroomBake modifier. It should be at the top of the mod stack, but below anim wires (if present). Click the bakeXPD button to write an XPD file to the bake folder of the xGen description.
- To use the XPD, in the Primitives tab change the Generate Primitives dropdown to "from XPD file" (instead of "randomly across the surface")
Texture Maps Overview
This is a three step process. Note that the texture UVs are based on the geometry the hair is growing from:
1. Create an xGen root_color attribute to connect the texture map to
   (See C. Root and Tip Color: Complex method (with texture maps) below)
2. Connect your texture map to the root_color attribute and convert it to ptex.
   (See A. Applying Texture Maps below)
3. Finally we need to get the xGen root_color attribute into our hair material.
   In the Hypershade, create a VrayHairSampler node and MMB-drag it into the desired color channel(s) of a VrayHairMaterial in the Attribute Editor.
   (The VrayHairSampler has many useful outputs, but the default is root_color)
A. Applying Texture Maps
1. Open hypershade, drag the scalp geometry's shape node into workspace, graph it.
2. To create a new file node, click the "paintable texture" icon. The map will appear in the hypershade.
3. Load the texture file you want into the appropriate file node (you can copy-paste the image path into the name slot in the attribute editor for the file node).
4. Click the xGen "save" icon to save as a ptex:
Assigning Materials and Multimattes
In Maya 2015 with Vray 3.0 this works quite simply:

**Materials:** Select the xGen description and assign the material.
Note that for archive geometry you will also need to check "use per patch/material description for archive" in the Vray Settings section of the xGen Preview/Output tab. Otherwise it will use the material assignment saved with the archive.

**Multimattes:** Either add a material ID to the VrayHairMtl3 (this did not work in previous versions), or add an Object ID to the xGen description.

Assigning Materials and Multimattes

In Maya 2015 with Vray 3.0 this works quite simply:

**Materials:** Select the xGen description and assign the material.
Note that for archive geometry you will also need to check "use per patch/material description for archive" in the Vray Settings section of the xGen Preview/Output tab. Otherwise it will use the material assignment saved with the archive.

**Multimattes:** Either add a material ID to the VrayHairMtl3 (this did not work in previous versions), or add an Object ID to the xGen description.
Combined Methods
In the following example we will combine the root fade and randomization techniques described above. Notice that the colors on ramp1 are predominantly red-orange-yellow with smaller portions being blue and green. This balance is reflected in the distribution of random colors on the beard in the render. Next notice that ramp2 goes from dark to light. This drives the root to tip of each hair, making it darker at the root. Below you can see how these two ramps are combined with a numbered walkthrough below.
To do the above using a randomized texture map you could output the root_color through the VRayHairSampler (1), run that through an HSVremap (2) and drive its value attribute with a ramp using shades of grey (3) driven by a "random by strand" attribute (4).
Stray hair
Here are two methods for getting noise to only affect a certain percentage of the hair.

1. **Procedural noise expression**
   Go to load expression>samples>xgen>waterRelatedExpression>noise>noise smoothstep. This will load an expression with a texture noise pattern. Next increase the contrast, and raise the low slider to add more black. This will act as a mask to give you noise on the small percentage of white in the texture.

2. **Stray hairs**
   Go to the menu Description > Set stray hair percentage and set it to 10%. Next in the magnitude of your noise modifier (or whatever you want to vary) type the following expression: stray() ? 10 : 1This is an if-then-else conditional statement that says if the hair is a stray make it 10, or else set it to 1. So 10% of the hairs will have a magnitude of 10 and the rest will have a magnitude of 1. Of course you can further control this with masks as well.
16주차 Fur 만들기 II

Setting up XGen

![Plug-in Manager for XGen setup](image)
Create or Load your Geometry
No secret here, I'll use my awesome modeling skills and create a Sphere.
Create your XGen Fur
Well, this is not meant to be a full on XGen tutorial, so I’ll only touch the basics here.
a) Click the Xgen icon in the XGen tab

b) Select the Geometry (or Faces) you want to grow hair on
Important! There is a bug with the current version of Maya and Vray

[Maya 2016 + Vray 3.4](I'm not sure where it is coming from). Make sure the object you want to grow hair on does not have a Vray Material applied. Lambert and Blinn are fine. I haven’t tested other materials. We will see a bit later on why.

c) Create new Description (Create the Fur)
Pictures are worth a lot of words:
Getting started with XGen

Use XGen to create arbitrary primitives on a surface:
hair, fur, feathers, scales, rocks, and more.

To start:
1- Select the geometry or faces to create primitive on.
2- Create a new XGen Description. A Description is a pattern for generating
primitives (hair, rocks, trees, etc)

Create New Description...
이미지 설명: Create XGen Description 창으로부터 캡처된 이미지.

- New Description Name: description
- Each Description must be stored in a Collection:
  - Add Description to existing Collection:
  - Create new Collection named: collection
- What kind of Primitives are made by this Description?
  - Spheres (use for long hair, vines, etc)
  - Groomable splines (use for short hair, fur, grass, etc)
  - Custom Geometry/Archives (use for any model you have created)
  - Spheres (use for pebbles, marbles, or other round objects)
  - Cards (use for scales or other flat textures)
- Generate the Primitives:
  - Randomly across the surface
  - In Uniform rows and columns
  - At points you specify
- Control the Primitives by:
  - Placing and shaping Guides
  - Using Attributes controlled by expressions
  - Using Grooming tools

해석과 해석: 16주차에서 제공한 Create XGen Description 창의 일부입니다.

- New Description Name은 기본 이름으로 'description'로 설정되어 있습니다.
- Each Description must be stored in a Collection은 상관된 Collection을 선택할 수 있습니다.
- What kind of Primitives are made by this Description?는 다음 항목들로 구성되어 있습니다:
  - Spheres (use for long hair, vines, etc)
  - Groomable splines (use for short hair, fur, grass, etc)
  - Custom Geometry/Archives (use for any model you have created)
  - Spheres (use for pebbles, marbles, or other round objects)
  - Cards (use for scales or other flat textures)
- Generate the Primitives은 다음과 같은 방법으로 지정할 수 있습니다:
  - Randomly across the surface
  - In Uniform rows and columns
  - At points you specify
- Control the Primitives is Placing and shaping Guides, Using Attributes controlled by expressions, Using Grooming tools로 설정할 수 있습니다.
16주차

Make Sure Vray is visible to XGen and set it as renderer:
d) Do your Grooming or whatever you were planning to do on the hair. In my case, I’m just increasing the density a bit, adjusting the length and taper, and adding a noise Modifier. I end up with something that looks like this:
4 – Color the hair
In order to color the hair, Vray uses custom shader parameters `root_color` and `tip_color`. If you only create one of the two, the whole hair will be colorized.
a) Create the custom Map
In “Custom Shader Parameters”, in the name field enter “root_color”, change the type to color, and click the “+” icon. Then, click “Create Map”.

Choose a resolution. This will be a PTex map (not UV map) and the resolution will be dependent of this value. I went for 400 sort of randomly, assuming it would be big enough. You can change it at any time by clicking the little expression icon.
At that point, you will see the sphere becoming white, and the 3D paint tool will be active. If you want to paint the color yourself, that’s fine, click the little paint icon next to the Custom Parameter. In my case, I want to use a texture file. If you look into the Hypershade, you will notice a texture and a material have been created for you. **This does not happen if your original object had a Vray Material applied!** That is the bug I mentioned earlier.
Click the Paint icon. You can now paint a custom color if you want to. (This step might not be necessary, but I failed last time I omitted it.)

Now in the Hypershade, double click the texture Map (pSphereShape1_collection_stom_color_root_color.iff in the image above), and browse to the texture you’d like to use instead.
Note: The color management might not be available, in which case you'll want a texture in Linear color. Make sure you click the little save icon to apply that map to Ptex.

It will look like nothing happened. However, if you browse to the right path, you'll notice you now have a ptex file.
Repeat the operation with “tip_color” if necessary. I will skip it, so my root_color will be applied on the whole hair.

5 – **Render It**
In order to render in Vray, I will change my renderer to Vray, and add a VrayLightDome to get some light in there. At that point, it’s still rendering as a grey hairy ball, but at least it’s rendering.
16주차

a) Create a shader
I will use a Vray Mtl Hair 3 Shader. In the diffuse, I attach a VRayHairSampler.
The hair sampler is the node doing the magic, it’s not very clear to me exactly how it links to the Ptex map. I’d like a bit more documentation on it, but somehow it can read some attributes of the XGen hair, and will recognize root_color and tip_color maps as such, and output them as Out color.

b) Assign the shader
Select the description, and assign the material to it:
16주차
c) Tweak your lighting / Shader, and Render
I replaced my dome light with two Rectangle lights, and removed the default brown color in the Hair material speculars. Here is the “final” render:

A magnificent hairy Earth.
Hope this Tutorial will be helpful for some. The process isn’t particularly intuitive and could be improved greatly, but for the time being we don’t have many options.
If you know a better way feel free to comment and let me know.
학원: 한중뉴미디어학원
강연교사: 金在奎

학과명칭: Advanced Compositing

학과번호: Visual Effects

과정유형: Required Subject

총 교시: 60
## 기 본 정 보

<table>
<thead>
<tr>
<th>강연교사</th>
<th>金在奎</th>
</tr>
</thead>
<tbody>
<tr>
<td>직 위</td>
<td>수업대상</td>
</tr>
<tr>
<td>학위</td>
<td>修士</td>
</tr>
<tr>
<td>(전공,학년)</td>
<td>영상 3 학년</td>
</tr>
<tr>
<td>학과명칭</td>
<td>학과번호</td>
</tr>
<tr>
<td>课程名称</td>
<td>课程代号</td>
</tr>
<tr>
<td>학과종류</td>
<td>Visual Effects</td>
</tr>
<tr>
<td>课程类型</td>
<td>教室(学程)</td>
</tr>
<tr>
<td>수업대상</td>
<td>3 학점, 60 교시</td>
</tr>
<tr>
<td>총 교 시</td>
<td>教室讲授(学程)</td>
</tr>
<tr>
<td>总课时</td>
<td>60 教室; 实習(学程)</td>
</tr>
<tr>
<td>评价方式</td>
<td>시험(考试)</td>
</tr>
<tr>
<td></td>
<td>시찰(考察)</td>
</tr>
<tr>
<td></td>
<td>기타(其他)</td>
</tr>
<tr>
<td>시험형식</td>
<td>open book(开放书)</td>
</tr>
<tr>
<td></td>
<td>closed book(封闭书)</td>
</tr>
<tr>
<td>考试方式</td>
<td>수업방식</td>
</tr>
<tr>
<td></td>
<td>멀티미디어及 实習课程结合</td>
</tr>
<tr>
<td>교재명칭</td>
<td>작 가</td>
</tr>
<tr>
<td>教材名称</td>
<td>作者</td>
</tr>
<tr>
<td>출판사</td>
<td>출판연도</td>
</tr>
<tr>
<td>出版社</td>
<td>出版日期</td>
</tr>
<tr>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td>연구실 검토 의견</td>
<td>연구실 주임(싸인) 년 월 일</td>
</tr>
<tr>
<td>학과 주임 검토 의견</td>
<td>학과 주임(싸인) 년 월 일</td>
</tr>
<tr>
<td>학원(부서) 검토 의견</td>
<td>교수 주관 담당자(싸인) 학원도장 년 월 일</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>학사일정 주간</th>
<th>수업내용 안배 (장,절 요점 기재)</th>
<th>교 시</th>
<th>수업형식 및 수단</th>
<th>수업 외 숙제 또는 지도 안배</th>
<th>집행 상황</th>
</tr>
</thead>
</table>
| 1 | 1. Visual Effect 개요  
2. Visual Effect History  
3. Orientation  
4. Program Interface Control  
5. Project Folder 만드는 법, 사용법  
6. Sprite Particles의 활용법  
7. Simulate Smoke와 Dust 제작 | 4 | 멀티미디어 수업 실천 조작 | 설습내용을 따라하고 있는지 파악하며 지도 |
| 2 | 1. 로케트엔진 연기효과 제작  
2. Particle Emitter 활용 | 4 |

1. 로케트엔진 연기효과 제작  
2. Particle Emitter 활용
<table>
<thead>
<tr>
<th>번호</th>
<th>주제</th>
<th>내 용</th>
</tr>
</thead>
<tbody>
<tr>
<td>3</td>
<td>3. Effects 메뉴의 Fire 사용법 4. ParticleShape 이해 5. Particle 과 Curve 의 연결</td>
<td>멀티미디어 수업 실천 조작 실습내용을 따라하고 있는지를 파악하며 지도</td>
</tr>
</tbody>
</table>
| 8  | 1. Simulating a Shattering Light Bulb  
2. Learning the characteristics of the bulb  
3. Breaking the bulb  
4. Creating a particle instancer  
5. Creating tungsten wire with nHair  
6. Exporting the nHair to the geometry cache  
7. create wispy smoke with fluids  
8. Achieving more realistic smoke | 4 | 멀티미디어 수업 실천 조작 | 중간고사 과제 제출 | 중간고사 과제 제출 |
| 9  | 1. Creating Fire and Smoke  
2. Understanding the science behind fire  
3. Creating the falling flames with particles  
4. Blending the fire and smoke  
5. Creating fire with smoke  
6. Using fluid presets to save time  
7. Creating the final composition | 4 | 멀티미디어 수업 실천 조작 | 실습내용을 따라하고 있는지 파악하며 지도 수업종 제작한 과제 제출 | 실습내용을 따라하고 있는지 파악하며 지도 수업종 제작한 과제 제출 |
| 10 | 1. Creative Realistic Fire and Sparks  
2. Creating of particles using emitters  
3. Particle collision event editor  
4. Controlling physics  
5. Looking at the aesthetics of sparks  
6. Using software render particles  
7. Placing our fluid and fluid emitter | 4 | 멀티미디어 수업 실천 조작 | 실습내용을 따라하고 있는지 파악하며 지도 수업종 제작한 과제 제출 | 실습내용을 따라하고 있는지 파악하며 지도 수업종 제작한 과제 제출 |
| 11 | 1. Creating Explosion  
2. Examining proper temperature settings  
3. Learning the aspects of fuel  
4. Shading explosion  
5. Revision of explosion settings  
6. Shading chunks  
7. Final composition workflow | 4 | 멀티미디어 수업 실천 조작 | 수업종 제작한 과제 제출 | 수업종 제작한 과제 제출 |
| 12 | 1. Simulating a Burning Tree  
2. Introduction to Smoke and Fire Container  
3. Understanding Scene Asset and Blocking of Fluid Containers  
4. Creating Emitter and Understand Container Properties  
5. Creating Density Section of Fluids  
6. Creating Velocity and Adding External Field | 4 | 멀티미디어 수업 실천 조작 | 수업중 제작한 과제 제출 |
| 13 | 1. Tornado Project I  
2. Creating a Tornado with NURB’s  
3. Using Particles on NURB’s Geometry  
4. Creating Secondary Particles  
5. Using External Field and Particle Cache  
6. Creating a Fluid Container  
7. Working on Fluid Shading  
8. Final Playblast and Cache Creations | 4 | 멀티미디어 수업 실천 조작 | 실습내용을 따라하고 있는지 파악하며 지도 |
| 14 | 1. Tornado Project II  
2. Creating a Particle System  
3. Creating a Fluid Container and Emitter  
4. Assigning External Volume Axis Field  
5. Applying Particle Instancer  
6. Replacing Instancer and Finalizing Effect | 4 | 멀티미디어 수업 실천 조작 | 수업중 제작한 과제 제출 |
| 15 | 1. Fur 만들기 I  
2. Getting started with XGen  
3. Understanding the tool layout and grooming menu  
4. Creating and Converting density texture maps  
5. Beginning the groom process  
6. Completing the basic groom  
7. Adjusting basic primitive setup | 4 | 멀티미디어 수업 실천 조작 | 실습내용을 따라하고 있는지 파악하며 지도 |
<table>
<thead>
<tr>
<th>8. Discussing basics of clumping</th>
</tr>
</thead>
<tbody>
<tr>
<td>16</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>4</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>
## 교육 목표 및 요구 사항


## 교육 중점

비주얼이펙트는 작게는 효과 구현 중심의 이펙트에서 시작하여 크게는 Effects, Simulation, rigid body dynamics, Lighting, Rendering, Compositing의 전 분야를 아우르는 포괄적인 개념으로도 볼 수 있다. 현재 비주얼이펙트 분야는 극장 개봉작으로부터 TV 시리즈에 이르기까지 다양하게 사용하고 있다. 비주얼이펙트 분야를 학습함으로서 학생들은 개개인이 정확히 원하는 올바른 직능 형성 및 개발에 도움을 준다. 또한 개개인별 맞춤형 강의와 과제를 통해 품질 높은 작품을 만들고 고급 수준의 기술 구현을 실현하고자 한다.

## 교육 방법

Lecture, Practice and Critique

수업방식: 讲授강의■ 探究 탐구□ 问答문답□V  实验실습■ 演示시연■

주요 수업방법: Practice, Homework, Mid-term and Final Project and Critique

수업수단: 板书출판물□ 多媒体멀티미디어■ 模型모형□ 实物시물□

주요 수업수단: 标本표본□ 挂图레도□ 音像음반□ 其他기타■

## 授課類型

## 강의 유형

- 理论課이론수업■
- 讨论課토론수업□
- 实验課실험수업□
- 练习課연습수업■
- 其他기타□

## 参考資料

## 교육과정

<table>
<thead>
<tr>
<th>번호</th>
<th>내용</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.</td>
<td>Visual Effect 개요</td>
</tr>
<tr>
<td></td>
<td>: Visual Effect 란?</td>
</tr>
<tr>
<td></td>
<td>: Visual Effect = FX + Lighting + Look Dev + Rendering + Compositing</td>
</tr>
<tr>
<td></td>
<td>: Visual Effect Reference</td>
</tr>
<tr>
<td>2.</td>
<td>Visual Effect History</td>
</tr>
<tr>
<td></td>
<td>: Visual Effect 의 역사 강의</td>
</tr>
<tr>
<td></td>
<td>: 시대별 Visual Effect 의 특징</td>
</tr>
<tr>
<td></td>
<td>: Visual Effect 의 구현사례 분석</td>
</tr>
<tr>
<td>3.</td>
<td>Orientation</td>
</tr>
<tr>
<td></td>
<td>: 수업개요</td>
</tr>
<tr>
<td></td>
<td>: 수업방식 소개</td>
</tr>
<tr>
<td></td>
<td>: 학점부여 방법 소개</td>
</tr>
<tr>
<td></td>
<td>: 작업공정 소개 및 질의응답</td>
</tr>
<tr>
<td>4.</td>
<td>Program Interface Control – 50 min</td>
</tr>
<tr>
<td></td>
<td>: Maya Dynamics Interface 소개</td>
</tr>
<tr>
<td></td>
<td>: Maya Dynamics Interface 학습 및 실습</td>
</tr>
<tr>
<td>5.</td>
<td>Sprite Particles 의 활용법</td>
</tr>
<tr>
<td></td>
<td>: Sprite Particles 소개</td>
</tr>
<tr>
<td></td>
<td>: Simulate Smoke 와 Dust 제작, 학습 및 실습</td>
</tr>
</tbody>
</table>

## 과제

과제 없음
教学后记  수업 후기. (手写손으로쓰기)
中韩新媒体学院()课程授课教案

<table>
<thead>
<tr>
<th>教研室</th>
<th>연구실 번호</th>
<th>任课教师 담당자</th>
<th>김재규</th>
</tr>
</thead>
<tbody>
<tr>
<td>授课</td>
<td>课题</td>
<td>강의주제</td>
<td>Visual Effect</td>
</tr>
<tr>
<td>研究</td>
<td>数量</td>
<td>授课时间长度</td>
<td>4 Hour</td>
</tr>
<tr>
<td>教学目标和要求</td>
<td>교육목표</td>
<td>教学重点</td>
<td>비주얼이펙트는 작게는 효과 구현 중심의 이펙트에서 시작하여 크게는 Effects, Simulation, rigid body dynamics, Lighting, Rendering, Compositing의 전 분야를 아우르는 포괄적인 개념으로도 볼 수 있다. 현재 비주얼이펙트 분야는 극장 개봉작부터 TV 시리즈에 이르기까지 다양하게 사용하고 있다. 비주얼이펙트 분야를 학습함으로써 학생들은 개개인이 정확히 원하는 올바른 직능 형성 및 개발에 도움을 준다. 또한 개개인별 맞춤형 강의와 과제를 통해 폼질 높은 작품을 만들고 고급 수준의 기술 구현을 실현하고자 한다.</td>
</tr>
<tr>
<td>教学难点</td>
<td>교수난점</td>
<td>教学方式</td>
<td>Lecture, Practice and Critique</td>
</tr>
<tr>
<td>教学方法分析</td>
<td>교육방법분석</td>
<td>수업방식: 授讲강의 ■ 探究탐구 □ 问答문답 □ V 实验실형 ■ 演示시연 ■ 练习연습 ■ 其他기타 □</td>
<td></td>
</tr>
<tr>
<td>教学手段分析</td>
<td>교육수단분석</td>
<td>Practice, Homework, Mid-term and Final Project and Critique</td>
<td></td>
</tr>
<tr>
<td>教学手段</td>
<td>교육수단</td>
<td>教学手段교학수단: 板书출판물 ■ 多媒体멀티미디어 ■ 模型모형 □ 实物시물 □ 标本표본 □ 挂图채도 □ 音像음반 □ 其他기타 □</td>
<td></td>
</tr>
<tr>
<td>授课类型</td>
<td>강의유형</td>
<td>理论课이론수업 ■ 讨论課토론수업 □ 实验課실형수업 □ 练习課연습수업 ■ 其他기타 □</td>
<td></td>
</tr>
</tbody>
</table>
1. 로켓엔진 연기효과 제작
   : Particle Emitter 활용

2. Effects 메뉴의 Fire 사용법
   : Fire Attributes 의미파악 및 사용하는 방법
   : Fire emitter type

3. ParticleShape 이해
   : ParticleShape 속성 이해
   : ParticleShape 속성 분석

4. Particle 과 Curve 의 애니메이션
   : Particle 과 Curve 연결방법
   : Particle 속성 이해 및 활용

5. Particle Emitter 사용
   : Particle Emitter 란?
   : Particle Emitter 생성 및 적용

6. Sprite Particles 활용
   : Creating a Smoke with Sprite Particles
   : Creating a Dust Impact Using Sprite

---

작업배치과제제출

과제 없음
### 教学后记

课后记录（手写记录）

<table>
<thead>
<tr>
<th>教学后记</th>
<th>课后记录</th>
<th>（手写记录）</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
# 中韩新媒体学院()课程授课教案

<table>
<thead>
<tr>
<th>课程号:</th>
<th>课程授课教案</th>
</tr>
</thead>
<tbody>
<tr>
<td>任课教师</td>
<td>김재규</td>
</tr>
<tr>
<td>授课时间长度</td>
<td>4 Hour</td>
</tr>
</tbody>
</table>

## 教研室

<table>
<thead>
<tr>
<th>教研室</th>
<th>研究室编号</th>
</tr>
</thead>
<tbody>
<tr>
<td>任课教师</td>
<td>담당자</td>
</tr>
</tbody>
</table>

## 课题

<table>
<thead>
<tr>
<th>课题</th>
<th>Visual Effect</th>
</tr>
</thead>
</table>

## 教学目标和要求

本课程是电影或动画制作过程中广泛使用Visual Effects部门的教育重点。Visual Effects的专业领域如Particle, Simulation, Fluid, Dynamics, Bifrost等中级过程理解和与之相关的应用过程学习。通过制作最终产品的照明, 渲染, 合成等后期工作通过各种实例和示例来学习。该课程通过视觉效果的全部过程进行全面理解和掌握，旨在高水准的讲授。本课程根据基本技能程度和韩语能力差异，教学成果差异较大。本课程是关于视觉效果的全面课程，从物理和化学概念包含在内，学生难以充分理解。

## 教学重点

- Visual Effects
- Simulation, rigid body dynamics, Lighting, Rendering, Compositing等
- TV 시리즈에 이르기까지 다양하게 사용되고 있는。

## 教学难点

- 由于视觉效果(视觉效果)的全面内容包含在内，对于学生来说有些困难。

## 教学方法

<table>
<thead>
<tr>
<th>教学方式</th>
<th>Lecture, Practice and Critique</th>
</tr>
</thead>
<tbody>
<tr>
<td>教学方法</td>
<td>分析</td>
</tr>
<tr>
<td>教学手段</td>
<td>Practice, Homework, Mid-term and Final Project and Critique</td>
</tr>
</tbody>
</table>

## 教学手段

- Practice, Homework, Mid-term and Final Project and Critique

## 参考资料

### 教学过程

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

1. 비오는 효과 제작
   - Introduction to Project workflow
   - Setting up the Shot

2. Rain and Splashes
   - Adding Events for Particles
   - Rendering Rain and Splashes
   - 3D Heat Haze
   - Compositing Heat Haze

3. Speed FX
   - Rendering Speed FX
   - Volume Fog
   - Tweaking the Final Simulation
   - Rendering Volume Fog

### 作业布置

비오는 효과 제작하여 E-Class 에 제출
| 教学后记  | 수업 후기. (手写손으로쓰기) |  |
中韩新媒体学院()课程授课教案

<table>
<thead>
<tr>
<th>课程号：</th>
<th>课程授课教案</th>
</tr>
</thead>
<tbody>
<tr>
<td>教研室</td>
<td>任课教师</td>
</tr>
<tr>
<td>号</td>
<td>담당자</td>
</tr>
<tr>
<td>号</td>
<td>김재규</td>
</tr>
<tr>
<td>授课</td>
<td>Visual Effect</td>
</tr>
<tr>
<td>课题</td>
<td>Visual Effect</td>
</tr>
<tr>
<td>教授</td>
<td>4 Hour</td>
</tr>
<tr>
<td>时间长度</td>
<td>4 Hour</td>
</tr>
</tbody>
</table>

### 教学目标和要求

本课程是电影或动画制作过程中广泛使用的视觉效果部门的教育重点课程。Visual Effects 的专业领域包括 Particle, Simulation, Fluid, Dynamics, Bifrost 等高级过程的理解和相关的应用过程的掌握，包括制作过程中的照明、渲染和合成等后期工作。通过高级课程的教授，全面理解和掌握视觉效果的全过程，达到熟练掌握和运用的目标。

### 教学重点

视觉效果是从实现效果为中心的特效开始，到 Effects, Simulation, rigid body dynamics, Lighting, Rendering, Compositing 的全面概念。视觉效果在从电影、电视剧系列到多样化地使用。学习视觉效果领域对学生的各种技能和能力的形成和发展有帮助。通过个别的课程设置和作业，实现高质量的作品和高级技术的实现。

### 教学难点

本课程根据基本技能的掌握程度和韩语使用能力，教学成果差异较大。本课程是教授视觉效果行业标准和行业的具体操作方法，涵盖物理和化学概念的教授，学生可能会在理解上遇到困难。

### 教学方法

- **Lecture, Practice and Critique**
  - 教学方式：讲授、研讨、问答、实验、演示
  - 练习：练习
  - 其他：

### 教学手段

- **Practice, Homework, Mid-term and Final Project and Critique**
  - 教学手段：板书、教具、多媒体、模型、实物、标本、挂图、音像、其他

### 授课类型

- 理论课程
- 讨论课程
- 实验课程
- 练习课程

### 参考资料

1. 하늘의 구름 효과 제작
   - Introduction to Project workflow
   - Setting up the Shot

2. Static cloud banks
   - Small Scale Tests and Emitters
   - Fine Tuning Settings for a Cloud Look
   - Simulating the Full Cloud Bank
   - Initial States and Dynamic Interaction
   - Simulating Setting up a Render Scene

3. Dynamic hero clouds
   - Setting up the Simulation for Hero Clouds
   - Adjusting the Simulation
   - Tweaking the Final Simulation
   - Secondary Effects
   - Setting up a Render Scene

하늘의 구름 효과 제작하여 E-Class 에 제출
<table>
<thead>
<tr>
<th>教学后记</th>
<th>수업 후기</th>
<th>(手写손으로쓰기)</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
中韩新媒体学院（）课程授课教案

### 课程号：

<table>
<thead>
<tr>
<th>教研室</th>
<th>任课教师</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>任课教师</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>课题</th>
<th>Visual Effect</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>教学时间长度</th>
<th>4 Hour</th>
</tr>
</thead>
</table>

### 教学目标和要求

本课程旨在电影或电视剧等视觉特效制作过程中广泛使用的Visual Effects部分进行教学。Visual Effects的子领域包括Particle, Simulation, Fluid, Dynamics, Bifrost等中级课程，并通过相关的应用课程进行学习。此外，将通过照明、渲染、合成等后期工作，通过各种实践和例子进行学习。旨在通过中级课程全面掌握视觉特效的过程，从而提高技能。

### 教学重点

- Visual Effects是效果实现为中心的特效，强调Effects, Simulation, rigid body dynamics, Lighting, Rendering, Compositing等领域的综合概念。视觉特效领域目前广泛用于从电影到电视剧的多种使用，通过个别人特有的课程和课题，旨在高层次的形成和开发。

### 教学难点

课程的理论和实践在一定程度上取决于学生的基本技能和韩国语能力，课程效果也会受到影响。课程包括视觉特效的全面教学，包括专业术语和物理、化学概念，需要准确理解，预计会有一些困难。

### 教学方法

- Lecture, Practice and Critique
- 探究
- 问答
- 实验
- 演示
- 联合
- 实习

### 教学手段

- Practice, Homework, Mid-term and Final Project and Critique
- 板书
- 多媒体
- 模型
- 实物
- 标本
- 银幕
- 音像
- 其他

### 教学类型

<table>
<thead>
<tr>
<th>类型</th>
<th>理论课</th>
<th>讨论课</th>
<th>实验课</th>
<th>综合实践课</th>
</tr>
</thead>
</table>

### 参考资料

# 教学过程

<table>
<thead>
<tr>
<th>1. nParticles 기법과 활용 I</th>
</tr>
</thead>
<tbody>
<tr>
<td>: Introduction to nParticles workflow</td>
</tr>
<tr>
<td>: nParticles Attributes 의미파악 및 사용하는 방법</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>2. Analyzing Your Assets</th>
</tr>
</thead>
<tbody>
<tr>
<td>: Painting Your Emission Rate Map</td>
</tr>
<tr>
<td>: Creating &amp; Animating the Newton Field</td>
</tr>
<tr>
<td>: Adding in the Air Field</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>3. Creating the Primary Energy Blast Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>: Adjusting the Volume Axis Curve for the Energy Blast</td>
</tr>
<tr>
<td>: Finalizing the Primary Energy Blast</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>4. Creating the Energy Ball Effect Pass</th>
</tr>
</thead>
<tbody>
<tr>
<td>: Emitting Particles from Particles</td>
</tr>
<tr>
<td>: Finalizing the Secondary Energy Blast Pass</td>
</tr>
<tr>
<td>: Reassembling All of the Energy Particle Passes</td>
</tr>
<tr>
<td>: Initial Setup for Rendering in Arnold</td>
</tr>
<tr>
<td>: Fine Tuning Arnold Render Settings</td>
</tr>
</tbody>
</table>

---

## 作业布置

| 과제 없음 |
教学后记 수업 후기. （手写손으로쓰기）
# 중한新媒体学院()课程授课教案

<table>
<thead>
<tr>
<th>教研室</th>
<th>任课教师</th>
</tr>
</thead>
<tbody>
<tr>
<td>研究실 번호</td>
<td>담당자</td>
</tr>
<tr>
<td>김재규</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>授课课题</th>
<th>教学目标和要求</th>
</tr>
</thead>
<tbody>
<tr>
<td>강의주제</td>
<td>교수목표</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>教学重点</th>
<th>教学难点</th>
</tr>
</thead>
<tbody>
<tr>
<td>교수중점</td>
<td>교수난점</td>
</tr>
<tr>
<td>비주얼이펙트는 작게는 효과 구현 중심의 이펙트에서 시작하여 크게는 Effects, Simulation, rigid body dynamics, Lighting, Rendering, Compositing의 전 분야를 아우르는 포괄적인 개념으로도 볼 수 있다. 현재 비주얼이펙트 분야는 극장 개봉작으로부터 TV 시리즈에 이르기까지 다양하게 사용하고 있다. 비주얼이펙트 분야를 학습함으로서 학생들 개개인이 정확히 원하는 올바른 직능 형성 및 개발에 도움을 준다. 또한 개개인별 맞춤형 강의와 과제를 통해 익히는 프로젝트의 결과물 프로젝트를 만드는 고급 수준의 기술 구현을 실현하고자 한다.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>教学方法分析</th>
<th>教学手段分析</th>
</tr>
</thead>
<tbody>
<tr>
<td>教学方式</td>
<td>教学手段교학수단</td>
</tr>
<tr>
<td>수업방식: 讲授강의</td>
<td>板书</td>
</tr>
<tr>
<td>探究 학습</td>
<td>多媒体</td>
</tr>
<tr>
<td>问答</td>
<td>模型</td>
</tr>
<tr>
<td>练习</td>
<td>实物</td>
</tr>
<tr>
<td>批判</td>
<td>表本표본</td>
</tr>
<tr>
<td>判断</td>
<td>挂图드로</td>
</tr>
<tr>
<td>演示</td>
<td>图像 음반</td>
</tr>
<tr>
<td>其他</td>
<td>其他 기타</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>授课类型</th>
<th>授课手段단면 분석</th>
</tr>
</thead>
<tbody>
<tr>
<td>강의유형</td>
<td>Practice, Homework, Mid-term and Final Project and Critique</td>
</tr>
<tr>
<td>实验</td>
<td>Utilities</td>
</tr>
<tr>
<td>练习</td>
<td>实物</td>
</tr>
<tr>
<td>讨论</td>
<td>模型 모형</td>
</tr>
<tr>
<td>理论</td>
<td>多媒体 멀티미디어</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>参考资料</th>
<th>참고자료</th>
</tr>
</thead>
</table>
1. nParticles 기법과 활용 II
   : Introduction to Project workflow
   : nParticles Attributes 사용하는 방법

2. Emission methods
   : Simulating Particles and Expressions
   : Blocking out Fluid Containers
   : Creating an External Field

3. Rendering the Fluid Container of Smoke with Arnold
   : Rendering the Fluid Container of Smoke with Arnold
   : Managing Render Layers to Break-down Fluid Container
   : Create Lighting Setup to Render Smoke
   : Creating a Shadow-pass of Smoke
   : Composing the Different Render Layers and Sequences

손에서 에너지 나가는 효과 표현하여 E-Class 에 제출
<table>
<thead>
<tr>
<th>教学后记</th>
<th>수업 후기. (手写손으로쓰기)</th>
</tr>
</thead>
</table>

# 중한新媒体学院()课程授课教案

<table>
<thead>
<tr>
<th>课程号:</th>
<th>课程授课教案</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>教研室</th>
<th>任课教师</th>
</tr>
</thead>
<tbody>
<tr>
<td>연구실 번호</td>
<td>담당자</td>
</tr>
<tr>
<td>김재규</td>
<td></td>
</tr>
</tbody>
</table>

| 授课  | Visual Effect |
| 课题 |  |
| 강의주제 |  |
|  | 4 Hour |

| 授课  | 授课  |
| 时间长度 | 강의시간 |
|  |  |

<table>
<thead>
<tr>
<th>教学目标和要求</th>
<th>教授목표</th>
</tr>
</thead>
<tbody>
<tr>
<td>Visual Effects의 전문분야인</td>
<td>Particle, Simulation, Fluid, Dynamics, Bifrost 등 중급 과정을 이해하고 이와 관련된</td>
</tr>
<tr>
<td>분야를 이해하고</td>
<td>응용 과정을 배운다. 또한 최종 결과물의 만드는데, 필요한 라이팅, 렌더링,</td>
</tr>
<tr>
<td>합성 등의</td>
<td>합성 등의 후반부 작업을 다양한 실습과 예제를 통해 학습한다. 비교적 수준 높은</td>
</tr>
<tr>
<td>수준을</td>
<td>강의의 통해 비주얼이펙트의 전 과정을 포괄적으로 익히고 습득하는데 목표를 둔다.</td>
</tr>
</tbody>
</table>

| 教学重点 | 教授중점 |
| 教学 | 비주얼이펙트는 작게는 효과 구현 중심의 이펙트에서 시작하여 크게는 Effects, |
| 重点 | Simulation, rigid body dynamics, Lighting, Rendering, Compositing의 전 분야를 |
| 教学 | 포괄적인 개념으로도 볼 수 있다. 현재 비주얼이펙트 분야는 극장 |
| 教学 | 개봉작부터 TV 시리즈에 이르기까지 다양하게 사용되고 있다. 비주얼이펙트 |
| 教学 | 분야의 학습함으로서 학생들의 개개인이 정확히 원하는 음바른 작업 형상 및 개발에 |
| 教学 | 도움을 준다. 또한 개개인별 맞춤형 강의와 과제를 통해 폼질 높은 작품을 만들고 |
| 教学 | 고급 수준의 기술을 익히고자 한다. |

| 教学难点 | 教授난점 |
| 教学 | 본 강의는 가르치는 것을 고려하여 크게는 Effects, Simulation, rigid body dynamics, Lighting, Rendering, Compositing의 전 분야를 |
| 教学 | 포괄적인 개념으로도 볼 수 있다. 현재 비주얼이펙트 분야는 극장 개봉작부터 TV 시리즈에 이르기까지 다양하게 사용되고 있다. 비주얼이펙트 |
| 教学 | 분야의 학습함으로서 학생들의 개개인이 정확히 원하는 음바른 작업 형상 및 개발에 |
| 教学 | 도움을 준다. 또한 개개인별 맞춤형 강의와 과제를 통해 폼질 높은 작품을 만들고 |
| 教学 | 고급 수준의 기술을 익히고자 한다. |

| 教学方法 | Lecture, Practice and Critique |
| 分析 | 教学방법분석 |
| 分析 | 수업방식: 讲授강의■ 探究탐구□ 问答문답□V  | 实验실험■  | 演示시연■  |
| 分析 | 练习연습■  | 其他기타■  |

| 教学手段 | Practice, Homework, Mid-term and Final Project and Critique |
| 分析 | 教学수단분석 |
| 分析 | 教学시작교학수단: 板書출판물□  | 多媒体멀티미디어□  | 模型모형□  | 実物시물□ |
| 分析 | 标本표본□  | 挂图挂도□  | 音像음반□  | 其他기타■ |

| 授课类型 | 理论课이론수업■  | 讨论課토론수업□  | 实验課실습수업□  | 练习課연습수업■ |
| 型 | 其他기타□ |


| 参考资料 | 참고자료 |
1. Simulating a Disintegration Effect
   : Introduction to Project workflow

2. Modifying fluids
   : Adding detail to selection set
   : Converting the mesh to nCloth
   : Adding a turbulence field
   : Modifying fields and creating nCache

3. Creating primary particles
   : Adding MEL expressions
   : Converting particles to an instance
   : Modifying the instance with MEL

수업중 제작한 프로젝트 작업하여 E-Class 에 제출
教学后记
수업 후기.  (手写손으로쓰기)
**Course Title:** Visual Effect

**Instructor:**

- **Instructor Name:** 김재규
- **Teaching Time:** 4 Hour

**Course Description:**

This course focuses on Visual Effects, which are broadly used in film, animation, and advertising. Students will learn about Particle, Simulation, Fluid, Dynamics, Bifrost, and related applications. They will also practice lighting, rendering, and compositing through various exercises and examples.

**Teaching Methods:**

- Lecture, Practice, and Critique
- Practice, Homework, Mid-term and Final Project and Critique

**Teaching Materials:**

1. Simulating a Shattering Light Bulb
   : Introduction to Project workflow

2. Creating a particle
   : Creating a particle instance
   : Creating secondary chunks

3. Creating tungsten wire with nHair
   : Exporting the nHair to the geometry cache
   : Beginning to create wispy smoke with fluids
   : Improving the look of our wispy smoke
   : Achieving more realistic smoke
   : Rendering blast

Shattering Light Project : 작업하여 E-Class 에 제출
<table>
<thead>
<tr>
<th>教学后记</th>
<th>수업 후기</th>
<th>(手写손으로쓰기)</th>
</tr>
</thead>
</table>


# 中韩新媒体学院（）课程授课教案

<table>
<thead>
<tr>
<th>课程号：</th>
<th>课程授课教案</th>
</tr>
</thead>
<tbody>
<tr>
<td>任课教师</td>
<td>김재규</td>
</tr>
<tr>
<td>授课时间长度</td>
<td>4 Hour</td>
</tr>
</tbody>
</table>

## 教学目标和要求

**教授目标**

本课程是以电影、动画、广告等影视制作过程中的特效部门为核心，重点讲解特效、模拟、流体、动力学、Bifrost等中高级课程，并通过相关应用过程的学习，最终能够制作出完整的动画。

本课程旨在为学生提供全面的视觉效果知识，使学生能够理解和掌握视觉效果的全过程。

## 教学重点

**教授重点**

视觉效果是从小型特效到大型特效的逐步发展过程。当前，视觉效果在电影制作、电视剧制作等各个领域得到广泛应用，通过本课程的学习，学生将能够掌握视觉效果的基本原理和应用。

## 教学难点

本课程的难点在于学生对视觉效果的理解和掌握，尤其是特效的原理和应用。

## 教学方法分析

**教学方式**

- 讲授
- 问答
- 实验

**教学手段**

- 讲座
- 实验
- 考试

## 授课类型

- 理论
- 实践

## 参考资料

1. Creating Fire and Smoke using Fluid Effects
   : Introduction to Project workflow

2. Understanding the science behind fire
   : Creating first bit of smoke
   : Creating the falling flames with Maya particles

3. Creating Fire and Smoke
   : Blending the fire and smoke
   : Creating fire with smoke
   : Using fluid presets to save time
   : Creating the final composition

作业布置과제제출

 수업중 제작한 프로젝트 작업하여 E-Class 에 제출
<table>
<thead>
<tr>
<th>教学后记</th>
<th>수업 후기</th>
<th>(手写손으로쓰기)</th>
</tr>
</thead>
</table>

中韩新媒体学院()课程授课教案

课程号: 任课教师
序号: 韩
教研室 号

任课
课题 Visual Effect
任课
教师

授课
时间长度

강의주제 Visual Effect
강의
4 Hour
강의 시간

강의의 주제

本
강의는 영화나 애니메이션 또는 광고 등 영상제작과정에서 전반적으로
사용되는 Visual Effects 부분에 교육의 중점을 둔다. Visual Effects의 전문분야인
Particle, Simulation, Fluid, Dynamics, Bifrost 등 중급 과정을 이해하고 이와 관련된
응용 과정을 배운다. 또한 최종 결과물을 만들어내기까지 필요한 라이팅, 렌더링,
합성 등의 후반부 작업을 다양한 실습과 예제를 통해 학습한다. 비교적 수준 높은
강의 통해 비주얼이펙트의 전 과정을 포괄적으로 익히고 습득하는데 목표를 둔다.

教学
重
点

비주얼이펙트는 작가의 효과 구현 중심의 이펙트에서 시작하여 크게는 Effects,
Simulation, rigid body dynamics, Lighting, Rendering, Compositing의 전 분야들
아우르는 포괄적인 개념으로도 볼 수 있다. 현재 비주얼이펙트 분야는 극장
개봉작부터 TV 시리즈에 이르기까지 다양하게 사용하고 있다. 비주얼이펙트
분야를 학습함으로서 학생들이 개개인이 정확히 원하는 올바른 직능 형성 및 개발에
도움을 준다. 또한 개개인별 맞춤형 강의와 과제를 통해 품질 높은 작품을 만들고
고급 수준의 기술 구현을 실현하고자 한다.

教学
难
点

본
강의는 기존 직능 습득 정도와 한국어 구사능력에 따라 수업 성과도의 차이를 많이
보인다. 본 강의는 시각효과(비주얼이펙트)에 대한 전반적인 사항을 가르치는 수업으로
강의내용 중 전문용어와 물리학적, 화학적 개념들이 다수 포함되어 있어 학생들은
정확히 이해시키는데 많은 어려움이 따를 것으로 예상된다.

教学
方
法

Lecture, Practice and Critique

教学方式

수업방식: 讲授 강의■ 探究 탐구□ 问答 문답□V 实验 실험■ 演示시연■
练习연습■ 其他기타■

教学
手
段

Practice, Homework, Mid-term and Final Project and Critique

教学手段

교육수단: 板书출판물□ 多媒体멀티미디어■ 模型모형□ 实物시물□
標本표본□ 挂图제도□ 音像음반□ 其他기타□

教学
类
型

Lecture, Practice and Critique

教学类型

Other기타□

参考
资
料


参考
要
求

任课
类型

全
他기타□
1. Creative Realistic Fire and Sparks
   : Introduction to Project workflow

2. Creating of particles
   : Creating of particles using emitters
   : Particle collision event editor
   : Controlling physics

3. Creating of sparks
   : Using software render particles
   : Building shading networks
   : Blocking out simulations
   : fluid emitter
   : Creating smoke
   : Creating the final compositions

수업중 제작한 프로젝트 작업하여 E-Class 에 제출
| 教学后记 | 수업 후기 | (手写손으로쓰기) |
# 中韩新媒体学院课程授课教案

<table>
<thead>
<tr>
<th>教研室</th>
<th>任课教师</th>
<th>授课时间长度</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>4 Hour</td>
</tr>
<tr>
<td></td>
<td></td>
<td>강의시간</td>
</tr>
<tr>
<td></td>
<td></td>
<td>강의주제: Visual Effect</td>
</tr>
</tbody>
</table>

## 教学目标和要求

本课程旨在介绍电影、动画或广告等影像制作过程中广泛使用的Visual Effects部门。将学习Particle, Simulation, Fluid, Dynamics, Bifrost等中高级过程，并理解相关应用过程。通过不同的实践和案例，学习制作最终结果所需的渲染、合成等后期工作。通过高级课程，全面理解并掌握视觉效果的整个过程。

## 教学重点

- **视觉效果**：从效果实现开始，涵盖Effects、Simulation、Rigid body dynamics、Lighting、Rendering、Compositing等全面的概念。
- 本课程以视觉效果(视觉效果)为主要内容，全面覆盖从特效到合成的各个方面，帮助学生建立准确的职能构建及发展。

## 教学方法

- **授课类型**：讲授、讨论、实验、练习
- **教学手段**：板书、多媒体、模型、实物、音像

## 参考资料

1. Creating Explosion
   : Introduction to Project workflow

2. Explaining a big explosion
   : Examining proper temperature settings
   : Learning the aspects of fuel
   : Shading of explosion
   : Revision of explosion settings

3. Creating Explosion chunks
   : Introduction to chunks
   : Shading of chunks
   : Final composition workflow

수업중 제작한 프로젝트 작업하여 E-Class 에 제출
教学后记

수업 후기. (手写손으로쓰기)
中韩新媒体学院() 课程授课教案

课程号：
序号：

<table>
<thead>
<tr>
<th>教研室</th>
<th>任课教师</th>
</tr>
</thead>
<tbody>
<tr>
<td>研究室 번호</td>
<td>담당자</td>
</tr>
<tr>
<td>김재규</td>
<td></td>
</tr>
</tbody>
</table>

授课

| 教授课题 | Visual Effect |
| 教授时间长度 | 4 Hour |

| 教学目标和要求 | 教授重点 |
| 教学目标和要求 | 教授重点 |
| 号 | |
| 教学重点 | 비주얼이펙트는 작게는 효과 구현 중심의 이펙트에서 시작하여 크게는 Effects, Simulation, rigid body dynamics, Lighting, Rendering, Compositing의 전 분야를 아우르는 포괄적인 개념으로도 볼 수 있다. 현재 비주얼이펙트 분야는 극장 개봉작부터 TV 시리즈에 이르기까지 다양하게 사용하고 있다. 비주얼이펙트 분야를 학습함으로서 학생들 개개인이 정확히 원하는 올바른 직능 형성 및 개발에 도움을 준다. 또한 개개인별 맞춤형 강의와 과제를 통해 품질 높은 작품을 만들고 고급 수준의 기술 구현을 실현하고자 한다. |
| 教学难点 | 본 강의는 기본 직능 습득 정도와 한국어 구사능력에 따라 수업 성과도의 차이를 많이 보인다. 본 강의는 시각효과(비주얼이펙트)에 대한 전반적인 사항을 가르치는 수업으로 강의내용 중전문용어와 물리학적, 화학적 개념들이 다수 포함되어 있어 학생들을 정확히 이해시키는데 많은 어려움이 따를 것으로 예상된다. |

| 教学方法 | Lecture, Practice and Critique |
| 教学方式 | 教学方法 |
| 分析 | 分析 |
| 수업방식: | 讲授강의■ 探究탐구□ 问答문답□V  | 实验실습■ 演示시연■  |
| 练习연습■  | 其他 기타■ |
| 教学手段 | Practice, Homework, Mid-term and Final Project and Critique |
| 教学手段 | 教学手段 |
| 分析 | 分析 |
| 教学手段교수수단: | 板书출판물□ 多媒体멀티미디어■ 模型모형□ 实物시물□ |
| 标本표본□ 挂图표도□ 音像음반□ 其他 기타■ |

| 授课类型 | 理论课이론수업■ 讨论課토론수업□ 实验課실습수업□ 练习课연습수업■ 其他기타□ |
| 강의형 | 理论课型 | 讨论课型 | 实验课型 | 练习课型 | 其他 |

| 参考 | 参考 |
| 资料 | 资料 |
1. Simulating a Burning Tree
   - Introduction to Project workflow

2. Creating Smoke and Fire Emitters
   - Introduction to Smoke and Fire Container
   - Understanding Blocking of Fluid Containers
   - Creating Emitter and Understand Container Properties
   - Creating Density Section of Fluids
   - Creating Velocity and Adding External Field

3. Working with Temperature Attributes of Fluid Container
   - Introduction to Module
   - Creating Temperature Attributes of Maya Fluid Container
   - Constructing Incandescence and Comparing Temperature Attributes
   - Creating Opacity Graph and Setting Cache Values
   - Calling Cache and Setting Lighting Attributes

4. Rendering The Fluid Container
   - Creating Render Layer for Fluid Beauty Pass
   - Create Render Layer for Shadow Pass
   - Setting Render Properties and Calling Image Sequences in After Effects

5. Adding Burning Embers to the Simulation
   - Creating Particle System
   - Linking the Particles with Motion of Fluids
   - Adding Additional Fields to Improvise Physics of Particles
수업 중 제작한 프로젝트 작업하여 E-Class 에 제출

<table>
<thead>
<tr>
<th>수업 후기</th>
<th>手写 손으로쓰기</th>
</tr>
</thead>
<tbody>
<tr>
<td>교육 후기</td>
<td>수업 후기</td>
</tr>
</tbody>
</table>
## 강의주제
Visual Effect

## 강의시간
4 Hour

## 교육목표

## 교수중점
비주얼이펙트는 작게는 효과 구현 중심의 이펙트에서 시작하여 크게는 Effects, Simulation, rigid body dynamics, Lighting, Rendering, Compositing의 전 분야를 아우르는 포괄적인 개념으로도 볼 수 있다. 현재 비주얼이펙트 분야는 극장 개봉작으로부터 TV 시리즈에 이르기까지 다양하게 사용하고 있다. 비주얼이펙트 분야를 학습함으로서 학생들이 개개인이 정확히 원하는 올바른 직능 형성 및 개발에 도움을 준다. 또한 개개인별 맞춤형 강의와 과제를 통해 품질 높은 작품을 만들고 고급 수준의 기술 구현을 실현하고자 한다.

## 교수난점
본 강의는 기본 적응 습득 정도와 한국어 구사능력에 따라 수업 성과도의 차이를 많이 보인다. 본 강의는 시각효과(비주얼이펙트)에 대한 전반적인 사항을 가르키는 수업으로 강의내용 중 전문용어와 물리학적, 화학적 개념들이 다수 포함되어 있어 학생들을 정확히 이해시키는데 많은 어려움이 따를 것으로 예상된다.

## 수업방식
Lecture, Practice and Critique

## 교학수단
Practice, Homework, Mid-term and Final Project and Critique

## 참고자료
1. Tornado Project I
   - Introduction to Project workflow
   - Creating a Tornado with NURB's
   - Using Particles on NURB's Geometry

2. Creating Secondary Particles
   - Using External Field and Particle Cache
   - Creating a Fluid Container
   - Creating a Fluid Emitter and Adjusting Properties
   - Working on Fluid Shading

3. Creating a Second Particle System
   - Creating a Fluid Container and Emitter
   - Adjusting Shading Properties
   - Creating a Fluid Container and Emitter
   - Assigning External Volume Axis Field
   - Discussing Important Cache Attributes

作业布置과제제출

과제 없음
<table>
<thead>
<tr>
<th>教学后记</th>
<th>수업 후기</th>
<th>(手写손으로쓰기)</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
# 중한新媒体学院()课程授课教案

<table>
<thead>
<tr>
<th>教研室</th>
<th>任课教师</th>
<th>김재규</th>
</tr>
</thead>
<tbody>
<tr>
<td>연구실 번호</td>
<td>授课时间长度</td>
<td>4 Hour</td>
</tr>
<tr>
<td>授课课题</td>
<td>강의 시간</td>
<td></td>
</tr>
<tr>
<td>강의주제</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Visual Effect</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### 授课类型
- 理论课
- 讨论课
- 实验课
- 练习课

### 授课手段
- Lecture
- Practice
- Homework
- Mid-term
- Final Project
- Critique

### 教学方式
- 讲授
- 探究
- 问答
- 实验
- 演示

### 教学内容
- Visual Effects
- Effects, Simulation, rigid body dynamics, Lighting, Rendering, Compositing

### 教学重点
- 비주얼이펙트는 작게는 효과 구현 중심의 이펙트에서 시작하여 크게는 Effects, Simulation, rigid body dynamics, Lighting, Rendering, Compositing의 전 분야를 아우르는 포괄적인 개념으로도 볼 수 있다. 현재 비주얼이펙트 분야는 극장 개봉작으로부터 TV 시리즈에 이르기까지 다양하게 사용되고 있다. 비주얼이펙트 분야를 학습함으로서 학생들이 개개인이 정확히 원하는 올바른 직능 형성 및 개발에 도움을 준다. 또한 개개인별 맞춤형 강의와 과제를 통해 품질 높은 작품을 만들고 고급 수준의 기술 구현을 실현하고자 한다.

### 教学难点
- 본 강의의 기본 직능 습득 정도와 한국어 구사능력에 따라 수업 성과도의 차이를 많이 보인다. 본 강의는 시각효과(비주얼이펙트)에 대한 전반적인 사항을 가르치는 수업으로 강의내용 중 전문용어와 물리학적, 화학적 개념들이 다수 포함되어 있어 학생들이 정확히 이해시키는데 많은 어려움이 따를 것으로 예상된다.

### 参考资料
1. Tornado Project II
   - Introduction to Project workflow

2. Creating a Particle System
   - Assign Volume Axis Field
   - Applying Particle Instancer
   - Adding Per-particle Attributes
   - Replacing Instancer and Finalizing Effect

3. Lighting and Rendering
   - Discussing Rendering and Scene File
   - Creating a Directional Light Setup
   - Creating a Sky-dome Light Setup
   - Finalizing Rendering and Render Layers

수업중 제작한 프로젝트 작업하여 E-Class 에 제출
<table>
<thead>
<tr>
<th>教学后记</th>
<th>수업 후기</th>
<th>(手写손으로쓰기)</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
# 중한新媒体学院() 课程授课教案

<table>
<thead>
<tr>
<th>教研室</th>
<th>任课教师</th>
</tr>
</thead>
<tbody>
<tr>
<td>연구실 번호</td>
<td>김재규</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>授课</th>
<th>Visual Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>教案</td>
<td>授课</td>
</tr>
<tr>
<td>课程号</td>
<td>课题</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>授时间长度</td>
<td>강의 시간</td>
</tr>
<tr>
<td>教学目标和要求</td>
<td>교수목표</td>
</tr>
<tr>
<td>教学重点和难点</td>
<td>교수중점</td>
</tr>
<tr>
<td>教学方法分析</td>
<td>교육방법분석</td>
</tr>
<tr>
<td>授课手段分析</td>
<td>수업방식: 讲授강의□ 探究탐구□ 问答문답□V 实验실습■ 演示시연□</td>
</tr>
<tr>
<td>授课类型</td>
<td>教育</td>
</tr>
<tr>
<td>教学手段分项</td>
<td>教学手段교학수단: 板书출판물□ 多媒体멀티미디어□ 模型모형□ 实物시물□ 标本표본□ 挂图 creado□ 音像음반□ 其他기타□</td>
</tr>
<tr>
<td>번역된 내용</td>
<td></td>
</tr>
<tr>
<td>-------------</td>
<td></td>
</tr>
</tbody>
</table>

| 학습 과정교육과정 |

1. Fur 만들기 I
   - Introduction to Project workflow

2. XGen 사용법
   - Getting started with XGen
   - Understanding the tool layout and grooming menu
   - Creating and Converting density texture maps
   - Beginning the groom process

3. Basic groom
   - Beginning the groom process
   - Completing the basic groom
   - Adjusting basic primitive setup
   - Discussing basics of clumping

<table>
<thead>
<tr>
<th>과제 제출</th>
</tr>
</thead>
</table>

과제 없음
<table>
<thead>
<tr>
<th>教学后记</th>
<th>수업 후기</th>
<th>（手写손으로쓰기）</th>
</tr>
</thead>
</table>


## 中韩新媒体学院（）课程授课教案

### 课程号:  任课教师:  김재규

<table>
<thead>
<tr>
<th>教研室</th>
<th>授课课题</th>
<th>时间长度</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Visual Effect</td>
<td>4 Hour</td>
</tr>
</tbody>
</table>

### 教学目标和要求

本课程是电影、动画、广告等影像制作过程中的视觉效果部分的重点课程。重点在于理解高级粒子、模拟、流体、动力学、Bifrost等专业领域，并学习相关的应用过程。此外，通过不同阶段的实践和案例，学生将学习照明、渲染，合成等后期工作。旨在通过中级课程，全面掌握视觉效果的全过程，并加深理解。

### 教学重点

- 视觉效果是从简单的效果到高级的Effects，Simulation，Rig body dynamics，Lighting，Rendering，Compositing的全面概念。
- 当前，视觉效果在从电影到电视系列的各个领域中广泛使用。
- 学生在学习视觉效果后，能够更准确地形成和培养适合个人的技能。

### 教学难点

- 课程根据学生的基础能力和韩语水平，教学成果会有所不同。
- 课程主要是关于视觉效果的全面内容，其中包含很多专业术语和物理、化学概念，学生可能难以理解。

### 教学方法

- 课堂讲授
- 探究
- 问答
- 实验
- 演示
- 练习

### 教学手段

- 板书
- 多媒体
- 模型
- 实物
- 音像

### 授课类型

- 理论课
- 讨论课
- 实验课
- 练习课

### 参考资料

### 教学过程

<table>
<thead>
<tr>
<th>1. Fur 만들기 II</th>
</tr>
</thead>
<tbody>
<tr>
<td>: Introduction to Project workflow</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>2. XGen Option의 활용</th>
</tr>
</thead>
<tbody>
<tr>
<td>: Setting up multiple clump layers</td>
</tr>
<tr>
<td>: Using cut and noise modifiers</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>3. Asymmetry의 활용</th>
</tr>
</thead>
<tbody>
<tr>
<td>: Introducing asymmetry</td>
</tr>
<tr>
<td>: Applying custom color attributes</td>
</tr>
<tr>
<td>: Creating nHair dynamics</td>
</tr>
<tr>
<td>: The nHair dynamics setup</td>
</tr>
<tr>
<td>: Finalizing Rendering and Render Layers</td>
</tr>
</tbody>
</table>

### 作业布置

기말고사 과제 : 효과의 주제를 선정하고 프로젝트 제작하여 E-Class 에 제출
教学后记：手写后记（手写손으로쓰기）